VS:Function Reference

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Classes

ActiveClass GetClLW LSByClass SetClLW
CLDropShadowEnabled GetClOpacity LWByClass SetClOpacity
ClassList GetClOpacityN MarkerByClass SetClPenBack
ClassNum GetClPenBack NameClass SetClPenFore
DelClass GetClPenFore OpacityByClass SetClTextStyleRef
EnableCLDropShadow GetClTextStyleRef OpacityByClassN SetClUseGraphic
FPatByClass GetClUseGraphic PenColorByClass SetClUseTextStyle
FillColorByClass GetClUseTextStyle RenameClass SetClUseTexture
GetCLDrpShadowData GetClVectorFill SetCLDrpShadowData SetClVectorFill
GetCVis GetClassArrow SetCLOpacityN SetClassArrow
GetClFPat GetClassBeginningMarker SetClFPat SetClassBeginningMarker
GetClFillBack GetClassEndMarker SetClFillBack SetClassEndMarker
GetClFillFore GetClassOptions SetClFillFore SetClassOptions
GetClLS GrayClass SetClLS ShowClass
GetClLSN HideClass SetClLSN

Color

RunColorPaletteMgr RunNewColorPalette RunPickClrFromPal

Command

Absolute DoMenuTextByName OpenPDFDocument PushAttrs
AcquireExportPDFSettingsAndLocation ExportPDFPages PenLoc Relative
AngleVar Move PopAttrs Run
ClosePDFDocument MoveTo PrintUsingPrintDialog SetTool
DoMenuText NoAngleVar PrintWithoutUsingPrintDialog

ConnectCAD

CC_CircuitFromShape CC_ReloadData CC_RouteFromShape
CC_DeviceFromShape CC_RoomFromShape CC_CircuitFromShape

Criteria

Angle EvalStr RoofArea_Heated WallAverageHeight
Area ForEachObject RoofArea_HeatedProj WallThickness
AreaN Height RoofArea_Total Width
BotBound Hide RoofArea_TotalProj XCenter
BotBoundN IsFlipped SelectObj XCenterN
CheckoutObj LeftBound Show XCoordinate
ComponentArea LeftBoundN SlabThickness YCenter
ComponentVolume Length SurfaceArea YCenterN
Count LengthN SurfaceAreaN YCoordinate
CriteriaArea ObjectType TopBound ZCenter
CriteriaSurfaceArea Perim TopBoundN ZCenterN
CriteriaVolume PerimN Volume ZCoordinate
DSelectObj ReleaseObj VolumeN
EditProperties RightBound WallArea_Gross
Eval RightBoundN WallArea_Net

Data Sheets

DSH_GetDSCount DSH_GetDSFieldValue DSH_GetDSNameAt
DSH_GetDSFieldInfoAt DSH_GetDSFieldsCount DSH_SetDSFieldValue

Data Tag Interface Library

DT_AssociateWithObj DT_BeginMultipleMove DT_EndMultipleMove DT_UpdateTaggedTags

Database / Record

DelRecord GetParametricRecord NewField Record
Field GetRField NumFields SetRField
GetFldFlag GetRFieldOpt NumRecords SetRFieldOpt
GetFldName GetRecord PopupGetChoices SetRecord
GetFldType LinkText PopupSetChoices

Dialogs - Modern

AddButtonMode CreateSwapPane GetNumImagePopupItems SetEdgeBinding
AddChoice CreateSymDispCtrlN GetNumLineTypeItems SetEditColorTextStyl
AddListBoxTabStop CreateSymbolDisplayControl GetPatternData SetEditInteger
AddRadioMode CreateTabControl GetPopUpChoiceIndex SetEditReal
AdjustComponentPixelPos CreateTabPane GetSelectedChoiceIndex SetFirstGroupItem
AlignItemEdge CreateThreeStateCheckBox GetSelectedChoiceInfo SetFirstLayoutItem
ClearGradientSliderSegments CreateThumbnailPopup GetSelectionRange SetFocusOnItem
CreateCenteredStaticText CreateTreeControl GetStoryBoundChoiceStrings SetGradientSlider
CreateCheckBox DeleteAllItems GetStoryBoundDataFromChoiceString SetGradientSliderData
CreateCheckBox2 DeregisterDialogFromTimerEvents GetStoryChoiceStrsN SetGradientSliderSelectedMarker
CreateCheckBoxGroupBox DeselectEditText GetThreeStateCheckBoxState SetHelpText
CreateClassPullDownMenu DialogTimerEventMessageC GetTreeControlItemData SetIconPushButtonState
CreateColorPopup DisplayDialogHelpC GetTreeControlItemText SetImageControlHandle
CreateControl DisplaySwapPane GetTreeControlSelectedItem SetImageControlPath
CreateCustThumbPopup DisplayTabPane GetTreeControlTextSelectedItem SetImagePopupSelectedItem
CreateCustomControl EnableItem InsertEnhanPullDownMenuItem SetItemClickable
CreateDesignLayerPullDownMenu EnableLBDropOnIndices InsertEnhancedPullDownMenuItem SetItemText
CreateEditColorText EnableTextEdit InsertGradientSliSeg SetItemToolTipText
CreateEditInteger ExpandTreeControlItem InsertGradientSliderSegment SetLBImageIndexes
CreateEditPassword GetActiveEditItem InsertImagePopupObjectItem SetLayoutDialogPosition
CreateEditReal GetActivePane InsertImagePopupResource SetLayoutDialogSize
CreateEditText GetBooleanItem InsertImagePopupSeparator SetLayoutOption
CreateEditTextBox GetChoiceCount InsertPropClassOrLayerItem SetLineAttributeData
CreateEnhancedPullDownMenu GetChoiceIndex InsertProposedClassOrLayerItem SetLineStyleChoice
CreateGradient GetChoiceStringFromStoryBoundData InsertTreeControlItem SetLineTypeAttriData
CreateGroupBox GetChoiceText IsClassChoiceSelected SetLineTypeChoice
CreateIconPushButton GetColorButton IsItemEnabled SetLineWeightChoice
CreateImageControl GetColorChoice IsItemVisible SetListBoxTabStops
CreateImageControl2 GetComponentRect LeftButtonC SetMarkerChoice
CreateImagePushButton GetComponentTextWidth NotifyPullDownClicked SetMarkerValue
CreateLayerPDMenu GetControlData RefreshItem SetPatternData
CreateLayout GetDlgCtrlWidthStdCh RegisterDialogForTimerEvents SetProportionalBinding
CreateLineAttributePopup GetEditInteger RemoveAllImagePopupItems SetRightItem
CreateLineStylePopup GetEditReal RemoveChoice SetSelectionRange
CreateLineWeightPopup GetGradientSlider RemoveEnhancedPullDownMenuItemRange SetSliderLiveUpdate
CreateListBox GetGradientSliderData RemoveGradientSliderSegment SetStaticTextColor
CreateListBoxN GetGradientSliderSelectedMarker RemoveImagePopupItem SetStaticTextColorN
CreateMarkerPopup GetIconPushButtonState RemoveListBoxTabStop SetStaticTextStyle
CreatePatternPopup GetImagePopupObject RemoveTreeControlItem SetThreeStateCheckBoxState
CreatePullDownMenu GetImagePopupObjectItemIndex ResizeDialogC SetTreeControlItemData
CreatePullDownMenuGroupBox GetImagePopupSelectedItem RunLayoutDialog SetVSResourceFile
CreatePullDownSearch GetItemText RunLayoutDialogN SetdownDialogC
CreatePushButton GetLBHeaderTextWidth RunNamedDialog SetupDialogC
CreateRadioButton GetLayoutDialogPosition RunNamedDialogN ShowByClassChoice
CreateRadioButton2 GetLayoutDialogSize SelectChoice ShowEditTileDialog
CreateRadioButtonGroupBox GetLineAttributeData SelectClassChoice ShowEditTileSettingsDialog
CreateResizableLayout GetLineStyleChoice SelectEditText ShowEnhancedPullDownMenuGroupIcon
CreateResourcePopup GetLineTypeAtIndex SelectTreeControlItem ShowItem
CreateRightStaticText GetLineTypeAttriData SetBelowItem ShowNewTileDialog
CreateSearchEditBox GetLineTypeChoice SetBooleanItem UpdateImageControl2
CreateSeparator GetLineWeightChoice SetColorButton UpdateImageControl3
CreateSheetLayerPullDownMenu GetMarkerChoice SetColorChoice UpdateImagePushButton
CreateStandardIconControl GetMarkerPopupSelectedItem SetComponentIndeterminate UpdateSymDispCtrlN
CreateStaticText GetMarkerValue SetComponentSize UpdateSymbolDisplayControl
CreateStyledStatic GetMultilineText SetControlData VerifyLayout
CreateSwapControl GetNumGradientSliderSegments SetControlText

Dialogs - Modern - Browser

AddLBImage GetLBColumnWidth HierLBItemClosed SetLBItemFillBackColor
AddLBOriginalName GetLBControlType HierLBItemIsClosed SetLBItemFillForeColor
AddListBrowserImage GetLBEditDisplayType HierLBItemIsContain SetLBItemGradientOrImageRefNumber
AreLBColumnLinesEnabled GetLBEventInfo HierLBItemOpened SetLBItemHatchRefNum
AreLBRadioColumnLinesEnabled GetLBItemDashStyle InsertLBColumn SetLBItemInfo
CollapseAllLBItems GetLBItemData InsertLBColumnDataItem SetLBItemInteracType
CreateLB GetLBItemDisplayType InsertLBItem SetLBItemLineType
DeleteAllLBItems GetLBItemFillBackColor IsLBColumnTrackingEnabled SetLBItemMkrByClass
DeleteLBColumn GetLBItemFillForeColor IsLBDisplayHier SetLBItemMkrChoice
DeleteLBItem GetLBItemGradientOrImageRefNumber IsLBItemReadOnly SetLBItemPatternIndex
EnableLB GetLBItemHatchRefNum IsLBItemSelected SetLBItemPenBackColor
EnableLBClickAllDataChange GetLBItemInfo IsLBReadOnly SetLBItemPenForeColor
EnableLBColumnLines GetLBItemLineType IsLBResOnlyCurDoc SetLBItemReadOnly
EnableLBColumnTracking GetLBItemMkrByClass IsLBSortingEnabled SetLBItemTextColor
EnableLBDragAndDrop GetLBItemMkrChoice RefreshLB SetLBItemTextColorN
EnableLBExternalSort GetLBItemOrigName RemoveAllLBColumnDataItems SetLBItemTextJust
EnableLBHierDisplay GetLBItemPatternIndex RemoveLBColumnDataItem SetLBItemTextStyle
EnableLBRadioColumnLines GetLBItemPenBackColor SetFocusOnLB SetLBItemTileRefNum
EnableLBSingleLineSelection GetLBItemPenForeColor SetLBColumnHeaderJust SetLBItemUsingColumnDataItem
EnableLBSorting GetLBItemTextColor SetLBColumnHeaderToolTip SetLBMultImageIndexes
EnableLBUpdates GetLBItemTextJust SetLBColumnImage SetLBNumericItemInfo
EnsureLBItemIsVisible GetLBItemTextStyle SetLBColumnOwnerDrawnType SetLBOrigNameClLevel
ExpandAllLBItems GetLBItemTileRefNum SetLBColumnWidth SetLBReadOnly
FindLBColumnDataItem GetLBMultImageIndexes SetLBControlType SetLBResOnlyCurDoc
FindLBColumnItem GetLBOrigNameClLevel SetLBDragDropColumn SetLBSelection
GetLBColumnDataItemInfo GetLBSortColumn SetLBEditDisplayType SetLBSortColumn
GetLBColumnHeaderJust GetNumLBColumnDataItems SetLBHierDispColumn ShowLBHeader
GetLBColumnHeaderToolTip GetNumLBColumns SetLBItemDashStyle ShowLBItemMkrByClass
GetLBColumnOwnerDrawnType GetNumLBItems SetLBItemData ShowLBItemMkrEditLst
GetLBColumnSortState GetNumSelectedLBItems SetLBItemDisplayType

Dialogs - Predefined

AlertCritical AlertQuestion DetailGraphicOptDlg NonUndoableActionOK
AlertCriticalHLink AlertQuestionDontShowAgain DidCancel PtDialog
AlertInform AlertSetAlwaysDoVal DistDialog PtDialog3D
AlertInformDontShowAgain AlrtDialog EditSymMarkersDlg RealDialog
AlertInformHLink AngDialog FormatTextDialog StrDialog
AlertInformHLinkN AngDialog3D IntDialog YNDialog

Dimensions

AngularDim DimArcText GetDimText SetDimNote
AssociateLinearDimension DimText HasDim SetDimText
CircularDim DoubleFixedTolerance LimitTolerance SingleTolerance
CreateChainDimension DoubleTolerance LinearDim

Document Attributes

AddTileGeometryObject FPenColorByClass GetGradientSpotColor SetDashStyle
CreateImageFromPaint FPenFore GetGradientSpotPosition SetDashStyleN
CreateImgFromSymbol FPenPat GetNumDashDataPairs SetDefOpacityByClsN
CreateImgFromSymbolN FPenPatN GetNumDashDataPairsN SetDefaultBeginningMarker
CreateTile FPenSize GetNumGradientSegments SetDefaultEndMarker
DS_GetAngle FillBack GetTileBackgroundColor SetDefaultOpacity
DS_GetFillStyle FillFore GetTileGeometryGroup SetDefaultOpacityByClass
DS_GetOffset FillPat GetTileGroupParent SetDefaultOpacityN
DS_GetOffsetUnit GetDashDataValPairAt GetTileOffsetPoint SetDocDrpShadowData
DS_GetOpacity GetDashDataValPrAtN GetTileRepetitionPoint SetDocDrpShadwByCls
DS_IsOpacityByClass GetDashStyle InsertGradientData SetDocumentDefaultSketchStyle
DS_IsUnderCanopy GetDashStyleIndex InsertGradientSegment SetGradientData
DefDrpShadowEnabled GetDashStyleIndexN IsTileGroupContainedObject SetGradientDataN
DocDropShadowByCls GetDashStyleN IsUserColor SetGradientMidpointPosition
EnableDefDropShadow GetDefOpacityByClsN Marker SetGradientOpacity
FFPatByClass GetDefaultBeginningMarker NumColors SetGradientSpotColor
FFillBack GetDefaultEndMarker NumDashStyles SetGradientSpotPosition
FFillColorByClass GetDefaultOpacity Opacity SetTileBackgroundColor
FFillFore GetDefaultOpacityN OpacityN SetTileOffsetPoint
FFillPat GetDocDrpShadowData PenBack SetTileRepetitionPoint
FLSByClass GetDocumentDefaultSketchStyle PenFore SheetList
FLWByClass GetGradientData PenPat SheetNum
FMarker GetGradientDataN PenPatN ShowCreateImageDialog
FMarkerByClass GetGradientMidpointPosition PenSize ShowGradientEditorDialog
FPenBack GetGradientOpacity RemoveGradientSegment ShowPlanShadowsTab

Document List Handling

AddResourceToList FInSymDef LSActLayer ResList_Filter
BeginFolder FObject NextDObj ResList_FilterNonAct
BeginFolderN FSActLayer NextLayer ResList_GetSel
BuildResourceList FSObject NextObj ResList_GetSelIsDoc
BuildResourceList2 FSymDef NextSObj ResList_ImportItem
BuildResourceListN ForEachMaterial NextSymDef ResList_ImportItemN
BuildResourceListN2 GetActualNameFromResourceList PrevDObj ResList_Init
DeleteResourceFromList GetNameFromResourceList PrevLayer ResList_InitDef
EndFolder GetResourceFromList PrevObj ResList_IsSelValid
FActLayer ImportResToCurFileN PrevSObj ResList_PropFilter
FIn3D ImportResourceToCurrentFile PrevSymDef ResList_SelFAvail
FInFolder LActLayer ResList_ActFolder ResList_SetSel
FInGroup LNewObj ResList_AddCont ResourceListSize
FInLayer LObject ResList_AddCont1 SetParent

Document Settings

DeleteAllDLComponents GetDLOptions InsertNewDLCompN SetDLOptions
DeleteDLComponent GetDLSeparation InsertNewDLComponent SetDLSeparation
DoubLines GetDefaultTextSize PenGrid SetDimStd
DrwSize GetDrawingSizeRect RunGridSettingsDlg SetOrigin
GetCurrentPlanarRefID GetDrawingSizeRectN SetConstrain SetOriginAbsolute
GetDLCompPenStylesN GetFName SetDLCompPenStylesN SetPref
GetDLComponentClass GetNumberOfDLComponents SetDLComponentClass SetPrefInt
GetDLComponentFill GetOrigin SetDLComponentFill SetPrefLongInt
GetDLComponentFillColors GetOriginInDocUnits SetDLComponentFillColors SetPrefRGB
GetDLComponentName GetPref SetDLComponentName SetPrefReal
GetDLComponentPenColors GetPrefInt SetDLComponentPenColors SetPrefString
GetDLComponentPenStyles GetPrefLongInt SetDLComponentPenStyles SetPrimaryDim
GetDLComponentPenWeights GetPrefRGB SetDLComponentPenWeights SetSecondaryDim
GetDLComponentUseFillClassAttr GetPrefReal SetDLComponentUseFillClassAttr SetUnits
GetDLComponentUsePenClassAttr GetPrefString SetDLComponentUsePenClassAttr SetWallPrefStyle
GetDLComponentWidth GetWallPrefStyle SetDLComponentWidth
GetDLControlOffset GridLines SetDLControlOffset

EnergyAnalysis Interface Library

EA_ConvDoc2X EA_DataAccCompGet EA_DataAccGetReal EA_DataAccSetReal
EA_ConvStr2X EA_DataAccCpyInto EA_DataAccGetStr EA_DataAccSetStr
EA_ConvX2Doc EA_DataAccCreate EA_DataAccMtrlDlg EA_GetUnitStr
EA_ConvX2DocStr EA_DataAccDelete EA_DataAccSave EA_IsUsedUValue
EA_DataAccAdvDlg EA_DataAccFillUI EA_DataAccSelUI EA_UValueText
EA_DataAccCompAdd EA_DataAccGetBool EA_DataAccSetBool
EA_DataAccCompDel EA_DataAccGetInt EA_DataAccSetInt

Excel

EXL_AddSheet EXL_GetCellBorderT EXL_GetSheetSize EXL_SetCellBorderR
EXL_CloseBook EXL_GetCellFill EXL_IsCellValid EXL_SetCellBorderT
EXL_DeleteSheet EXL_GetCellFont EXL_NewBook EXL_SetCellFont
EXL_GetCellAlignment EXL_GetCellStyle EXL_ReadFile EXL_SetCellNumFormula
EXL_GetCellBordeDiff EXL_GetCellValue EXL_SaveAndCloseBook EXL_SetCellNumber
EXL_GetCellBorderB EXL_GetSheetCnt EXL_SetCellAlignment EXL_SetCellStrFormula
EXL_GetCellBorderL EXL_GetSheetIndex EXL_SetCellBorderB EXL_SetCellString
EXL_GetCellBorderR EXL_GetSheetName EXL_SetCellBorderL Excel_Convert

File I/O

Append FindFile ImportIGES Space
Close FindFileInPluginFolder ImportParasolidXT StdRead
ConvertHSF2PosixPath GetFPathName ImportSAT StdReadLn
ConvertPosix2HSFPath GetFile ImportSketchup1 Tab
CreateFolder GetFileInfo Open UseDefaultFileErrorHandling
EOF GetFileN PutFile Write
EOLN GetFileSize Read WriteBin
ExportIGES GetFilesInFolder ReadBin WriteLn
ExportSAT GetFolder ReadLn WriteLnMac
ExportSTEP GetFolderPath Rewrite WriteMac
ExportSTL GetLastFileErr SaveActiveDocument

GIS

BindLayerToArcGISFS GetGISOrigin LegacyShapefileExp UpdateLayerFromFS
BindLayerToWFSFS GetGISOriginN LegacyShapefileImp VWCoordToGeog
EditGeorefWithUI GetProjectionLocName RemoveGeoref VWCoordToGeogN
GeogCoordToVW GetProjectionProj4 SetDocGeoRefByUsrOrg
GeogCoordToVWN GetProjectionWKT SetGISLayer
GetAngleToNorth IsGeoreferenced UpdateFeatureLayer

General Edit

AlignDistribute2D Forward MirrorXY3D RotatePoint
AlignDistribute3D GetNumResourceTags MoveBack Scale
Backward GetObjectTags MoveFront SetObjectTags
CreateScriptResource GetResourceTags ResetOrientation3D SetResourceTags
FlipHor GetScriptResource Rotate SetScriptResource
FlipVer LckObjs Rotate3D UnLckObjs

Graphic Calculation

CalcPolySegLen Eq GetWallHeight PtInPoly
Centroid EqPercent GetZatXY PtInRect
CircleCircleInters EqPt HCenter PtOnArc
ClipPolygon EqPt2D LineCircleIntersect PtOnLine
ClosestPoints EqPt3D LineEllipseIntersect PtPerpCircle
Cloud EqualPt LineLineIntersection PtPerpLine
CombinePolygons EqualRect OffsetPoly RegularPolygon
ConvertToArcPolyline FindObjAtPt_Create OffsetPolyN RelativeCoords
ConvertToPolygon FindObjAtPt_Create3D OverlapLineArc Split2DObjectByLine
ConvertToPolyline FindObjAtPt_Delete OverlapLineLine SrndArea
CutProfileHoles FindObjAtPt_GetCount PointAlongPoly Stipple
Distance FindObjAtPt_GetObj PointAlongPolyN SubtractPolygon
Distance3D GetObjectHiddenLine PolyMedialAxis ThreePtCenter
EllipseEllipseIntersect GetPtInPoly Polygonize UnionRect

Hatches / Vector Fills

AddVectorFillLayer CreateStaticHatchFromObject GetVectorFill SetVectorFill
BeginVectorFillN DelVectorFill GetVectorFillDefault SetVectorFillDefault
CreateStaticHatch EndVectorFill NumVectorFills VectorFillList

IFC

IFC_AddDSField IFC_DMGetObjCond IFC_DMSetPSetFldOpt IFC_GetSpaceParamFO
IFC_AddObjectMapping IFC_DMGetObjCondAt IFC_DMSetPSetFldType IFC_GetStructureGUID
IFC_AddRecToObjMap IFC_DMGetObjNameAt IFC_DefPsetAddMember IFC_GetZSGField
IFC_AttachPSetToZSG IFC_DMGetObjectsCnt IFC_DefPsetBegin IFC_GetZSGPSetField
IFC_AttachPset IFC_DMGetPSetCond IFC_DefPsetEnd IFC_ImportLibrary
IFC_ClearAllPsets IFC_DMGetPSetFldMap IFC_DefPsetImport IFC_ImportNoUI
IFC_ClearIFCInfo IFC_DMGetPSetFldName IFC_DefPsetImport2 IFC_ImportWithUI
IFC_ClearPset IFC_DMGetPSetFldType IFC_DelRecFromObjMap IFC_IsFieldVisible
IFC_CopyIFCData IFC_DMGetPSetFldsCnt IFC_DeleteDS IFC_IsPsetCustom
IFC_CreateDS IFC_DMGetPSetName IFC_DeleteDSField IFC_IsPsetDefined
IFC_CreateObjGUID IFC_DMIsEntryEnabled IFC_DeleteIFCInfo IFC_IsRecEnabled
IFC_CreateZSG IFC_DMIsFieldEmpty IFC_DeleteObjectMap IFC_LAreIFCResLocal
IFC_DMAddEntry IFC_DMIsFieldEnabled IFC_ExportNoUI IFC_LGetLangFromDoc
IFC_DMAddField IFC_DMIsFieldOpt IFC_ExportWithUI IFC_LGetLocalName
IFC_DMAddPSetFld IFC_DMIsObjEnabled IFC_GetDSCount IFC_LGetUnivName
IFC_DMAddPSetForEnt IFC_DMIsPSetEnabled IFC_GetDSFieldInfoAt IFC_LSetLangInDoc
IFC_DMAddPSetInEntry IFC_DMIsPSetFldEmpty IFC_GetDSFieldsCount IFC_LSetLangInVW
IFC_DMDelPSetFromEnt IFC_DMIsPSetFldEnbl IFC_GetDSNameAt IFC_ReadProjectData
IFC_DMDeleteEntry IFC_DMIsPSetFldOpt IFC_GetEntityColor IFC_SetDSFieldVis
IFC_DMDeleteField IFC_DMLoadSettings IFC_GetEntityProp IFC_SetEntityColor
IFC_DMDeletePSetFld IFC_DMResToCOBieDef IFC_GetEntityProp2 IFC_SetEntityProp
IFC_DMEnableEntry IFC_DMResetToDef IFC_GetIFCEntity IFC_SetFieldVisible
IFC_DMEnableObject IFC_DMSaveSettings IFC_GetIFCEntity2 IFC_SetIFCEntity
IFC_DMEnablePSet IFC_DMSetEntryType IFC_GetIFCName IFC_SetIFCEntity2
IFC_DMGetEntPSetsCnt IFC_DMSetFieldEmpty IFC_GetIFCScheme IFC_SetIFCScheme
IFC_DMGetEntriesCnt IFC_DMSetFieldEnable IFC_GetNumPsetProps IFC_SetProperty
IFC_DMGetEntryName IFC_DMSetFieldMap IFC_GetNumPsets IFC_SetPsetProp
IFC_DMGetEntryType IFC_DMSetFieldOpt IFC_GetNumPsets2 IFC_SetRecEnabled
IFC_DMGetFieldMap IFC_DMSetFieldType IFC_GetPsetInfoAt IFC_SetStructureGUID
IFC_DMGetFieldName IFC_DMSetObjectCond IFC_GetPsetName IFC_SetZSGField
IFC_DMGetFieldType IFC_DMSetPSetFldEmpt IFC_GetPsetProp IFC_SetZSGPSetField
IFC_DMGetFieldsCount IFC_DMSetPSetFldEnbl IFC_GetPsetProp2 IFC_WriteProjectData
IFC_DMGetObjCategory IFC_DMSetPSetFldMap IFC_GetPsetPropName ReplaceIFCWithMap

ImportExport

DXFScaleString ImportDXFDWG ImportSketchUp SetDXFColorToLW
ExportDXFDWG ImportDXFDWGFile Init3DSServices SetLTGeneration
GetDXFColorToLW ImportOBJ InitDWGServices SetLastDXFImportOpt
GetLastDXFImportOpt ImportRevit InitRevitServices
Import3DSFile ImportSingleDXFDWG PublishSavedSet

Layers

ActLayer GetLayerCutPlane GetStoryLayerTemplateName SetDefStoryLayerName
AddLevelFromTemplate GetLayerElevation GetStoryOfLayer SetLScale
AddStoryLevel GetLayerEnableCutPl GetStorySuffix SetLayerCutPlane
AssociateLayerWithStory GetLayerForStory GetZVals SetLayerElevation
CopyMode GetLayerLevelType GrayLayer SetLayerEnableCutPl
CreateLayer GetLayerOptions HGetLayerTransp SetLayerLevelType
CreateLayerLevelType GetLayerRenderMode HSetLayerTransp SetLayerOptions
CreateLevelTemplate GetLayerTransparency HideLayer SetLayerRenderMode
CreateStory GetLevelElevation IsLayerReferenced SetLayerTransparency
CreateStoryLayerTemplate GetLevelTemplateInfo LFillBack SetLevelElevation
DeleteLevelTemplate GetLevelTemplateName LFillFore SetLevelTemplateName
DeleteStoryLayerTemplate GetLevelTypeName LLayer SetLevelTypeName
DisplayLayerScaleDialog GetNumLayerLevelTypes LPenBack SetScale
FLayer GetNumLevelTemplates LPenFore SetSheetLayerUserOrigin
GetDrawingArea GetNumStories Layer SetStoryElevation
GetLName GetNumStoryLayerTemplates LayerRef SetStorySuffix
GetLScale GetSheetLayerUserOrigin NumLayers SetZVals
GetLVis GetStoryAbove NumObj ShowLayer
GetLayer GetStoryBelow RemoveStoryLevel
GetLayerByName GetStoryElevation ResetDefStoryLevels

Math - General

Abs Deg2Rad Rad2Deg Sqrt
ArcCos Exp Random Tan
ArcSin Ln Round Trunc
ArcTan Max Sin
Cos Min Sqr

Math - Vectors

Ang2Vec CrossProduct Perp
AngBVec DotProduct UnitVec
Comp Norm Vec2Ang

ODBC

DBDiagnose DBDocRemoveConn DBObjSQLSetWrite DBSetFormatConn
DBDocAddConn DBDocSetColKey DBSQLExecute DBSetFormatFieldConn
DBDocGetColumns DBGetFormatConn DBSQLExecuteDSN DBShowDBTableDlg
DBDocGetConn DBGetFormatFieldConn DBSQLExecuteDelete DBShowManageDBsDlg
DBDocGetDB DBObjSQLGetRead DBSQLExecuteError DBShowObjConnDlg
DBDocGetTables DBObjSQLGetWrite DBSQLExecuteGet
DBDocHasConn DBObjSQLSetRead DBSQLExecuteNext

Object Attributes

AddSubMtrlToMtrl GetMaterialVolume IsMtrlFillStyleByCls SetLWByClass
CountFillSpaces GetMtlFillBackColor IsObjectFlipped SetMarker
CreateFillSpace GetMtlFillForeColor IsPenColorByClass SetMarkerByClass
CreateMaterial GetMtlPenBackColor IsPlanarObj SetMaterialFillStyle
EnableDropShadow GetMtlPenForeColor IsTextStyleByClass SetMaterialTexture
GetClass GetObjArrow RemoveSubMtrlFromMtl SetMtlFillBackColor
GetDescriptionText GetObjBeginningMarker SetClass SetMtlFillForeColor
GetDropShadowByCls GetObjEndMarker SetClassN SetMtlFillStyleByCls
GetDropShadowData GetObjMaterialHandle SetDescriptionText SetMtlPenBackColor
GetEntityMatrix GetObjMaterialName SetDropShadowByCls SetMtlPenForeColor
GetFPat GetObjTypeProperties SetDropShadowData SetObjArrow
GetFillBack GetOpacity SetEntityMatrix SetObjBeginningMarker
GetFillFore GetOpacityByClass SetEntityMatrixN SetObjEndMarker
GetFillIAxisEndPoint GetOpacityByClassN SetFPat SetObjMaterialHandle
GetFillJAxisEndPoint GetOpacityN SetFPatByClass SetOpacity
GetFillOriginPoint GetPenBack SetFillBack SetOpacityByClass
GetFillPoints GetPenFore SetFillColorByClass SetOpacityByClassN
GetFillSpace GetViewMatrix SetFillFore SetOpacityN
GetLS IsDropShadowEnabled SetFillIAxisEndPoint SetPenBack
GetLSN IsFPatByClass SetFillJAxisEndPoint SetPenColorByClass
GetLW IsFillColorByClass SetFillOriginPoint SetPenFore
GetMarker IsLSByClass SetLS SetTextStyleByClass
GetMaterialArea IsLWByClass SetLSByClass SetViewMatrix
GetMaterialFillStyle IsMarkerByClass SetLSN UpdateSubMtrlInMtrl
GetMaterialTexture IsMaterialSimple SetLW UpdateThumbnailPreview

Object Editing

BeginMultipleDuplicate EditObjectSpecial HMoveForward Move3DObj
CreateDuplicateObjN EndMultipleDuplicate HRotate MoveObjs
CreateDuplicateObject GetAssociation HScale2D OffsetHandle
DelObject GetNumAssociations HScale3D ResetBBox
DeleteObjs HDuplicate Mirror SetBBox
DeleteSymbolDefinition HMove MirrorN SetHDef
Duplicate HMoveBackward Move3D SetRRDiam

Object Events

AddAssociation vsoContextM_Add vsoPrmName2WidgetID vsoWidgetGetEnable
GetEvent vsoContextM_AddN vsoSetClosureGap vsoWidgetGetRecParam
GetXPropVersion vsoContextM_AddSep vsoSetEventResult vsoWidgetGetText
RemoveAssociation vsoContextM_Check vsoSetGlazingArea vsoWidgetGetVisible
SetCntrlPtVis vsoContextM_Enable vsoSetInCurtainWall vsoWidgetPopupAdd
SetObjPropCharVS vsoContextM_GetItem vsoSetIntSizeInfo vsoWidgetPopupAddN
SetObjPropDoubleVS vsoDisableAttrs vsoSetObjToolName vsoWidgetPopupClear
SetObjPropTxtVS vsoEIDataGetContext vsoSetQTOValue vsoWidgetPopupClearN
SetObjPropVS vsoEquipItemDataGet vsoSetSubtractPanels vsoWidgetPopupEnergy
vsoADPAddDimDef vsoEquipItemDataSet vsoStateAddCurrent vsoWidgetPopupGet
vsoADPAddDimPlace vsoGetCWInfo vsoStateClear vsoWidgetPopupGetCnt
vsoADPBeginDimType vsoGetCatalogPath vsoStateGet vsoWidgetPopupGetID
vsoADPGetDimDefParms vsoGetEventInfo vsoStateGetExitGroup vsoWidgetPopupGetTxt
vsoADPGetUniTypeName vsoGetIntSizeInfo vsoStateGetLayrChng vsoWidgetPopupSet
vsoADPGetViewType vsoGetPluginStyleSym vsoStateGetNameChng vsoWidgetSetBound
vsoADPSetCatName vsoGetQTOFunction vsoStateGetObjChng vsoWidgetSetEnable
vsoADPSetLocTypeName vsoGetUseLyrCutPlane vsoStateGetParamChng vsoWidgetSetIndLvl
vsoAddParamWidget vsoInsertAllParams vsoStateGetPos vsoWidgetSetText
vsoAddWidget vsoInsertParamWidget vsoStateGetRot vsoWidgetSetType
vsoAppendParamWidget vsoInsertWidget vsoStateGetRotN vsoWidgetSetVisible
vsoAppendWidget vsoPFCGetContext vsoStateMaterialChng
vsoButtonGetResource vsoPFCSetChanged vsoStyleWidgetChoice
vsoCanEditParam vsoParamName2Index vsoWSGetParamForEdit

Object Info

ConsolidatePlanar GetObjectVariableReal HAreaN SetObjectVariableBoolean
Get2DPt GetObjectVariableString HHeight SetObjectVariableHandle
GetBBox GetParent HLength SetObjectVariableInt
GetObjectByUuid GetPlanarRef HPerim SetObjectVariableLongInt
GetObjectUuid GetSymLoc HPerimN SetObjectVariablePoint
GetObjectVariableBoolean GetSymRot HWidth SetObjectVariableReal
GetObjectVariableHandle GetType ObjArea SetObjectVariableString
GetObjectVariableInt GetTypeN ObjAreaN SetPlanarRef
GetObjectVariableLongInt HAngle SetAngle SetPlanarRefIDToGround
GetObjectVariablePoint HArea SetHeight SetWidth

Object Names

DelName GetName NameList SetDashLineTypeName
GetColorName GetObject NameNum SetDashStyleName
GetDashLineTypeName Index2Name NameObject SetName
GetDashStyleName Name2Index SetColorName

Objects - 2D

AddHole CreateRenderBkg Locus RRectangleN
AddSurface GetArc MakePolygon Rect
Arc GetLocPt MakePolyline RectangleN
ArcByCenter GetRRDiam ModelPt2DToScreenPt ScreenPtToModelPt2D
ClipSurface GetSegPt1 ModelVecToScreenVec ScreenVecToModelVec
ClipSurfaceN GetSegPt2 OffsetPolyClosed SetArc
CombineIntoSurface IntersectSurface Oval SetSegPt1
Create2DObjShadow Line OvalN SetSegPt2
CreateRWBackground LineTo RRect

Objects - 3D

Add3DPt CreateExtrudeAlongPath Flip3DObj MeshToGroup
AddVertex3D CreateImageProp Get3DCntr Moments3D
BeginMXtrd CreateTaperedExtrd2 Get3DInfo Poly3D
BeginMesh CreateTaperedExtrude Get3DOrientation Products3D
BeginPoly3D EndMXtrd GetLocus3D Set3DInfo
BeginSweep EndMesh GetMeshVertex Set3DRot
BeginXtrd EndPoly3D GetMeshVertsCnt SetMeshVertex
Centroid3D EndSweep GetPolyPt3D SetPolyPt3D
ConvertTo3DPolys EndXtrd HExtrude SetRot3D
CreateContourCurves ExtrudeAlongPath Locus3D

Objects - Architectural

BeginColumn GetCompWallAssMod GetSlabHeight SetCompUseClassRPW
BeginFloor GetComponentAutoBoundEdgeOffset GetSlabPreferences SetCompWallAssBound
ConvertToUnstyledSlab GetComponentClass GetSlabPreferencesStyle SetCompWallAssMod
CreateRoofStyle GetComponentFill GetSlabStyle SetComponentAutoBoundEdgeOffset
CreateSlab GetComponentFillColors GetStoryLayerInfo SetComponentClass
CreateSlabStyle GetComponentFollowBottomWallPeaks GetTaperedComponent SetComponentFill
DelObjStoryBound GetComponentFollowTopWallPeaks GetWallPreferences SetComponentFillColors
DelObjStoryBounds GetComponentFunction HasObjStoryBound SetComponentFollowBottomWallPeaks
DeleteAllComponents GetComponentManualEdgeOffset HasObjStoryBounds SetComponentFollowTopWallPeaks
DeleteComponent GetComponentMaterial InsertNewComponent SetComponentFunction
GetCompABoundEOffOff GetComponentName InsertNewComponentN SetComponentManualEdgeOffset
GetCompAltSecFill GetComponentNetArea ModifySlab SetComponentMaterial
GetCompAltSecFillCl GetComponentNetVolume SetCompABoundEOffOff SetComponentName
GetCompAutoJoinCap GetComponentPenColors SetCompAltSecFill SetComponentPenColors
GetCompBotIsRelStory GetComponentPenStyles SetCompAltSecFillCl SetComponentPenStyles
GetCompBoundOffset GetComponentPenWeights SetCompAutoJoinCap SetComponentPenWeights
GetCompDatTopOfComp GetComponentTexture SetCompBotIsRelStory SetComponentTexture
GetCompInsertLoc GetComponentUseFillClassAttr SetCompBoundOffset SetComponentUseFillClassAttr
GetCompInsertLocOff GetComponentUsePenClassAttr SetCompDatTopOfComp SetComponentUsePenClassAttr
GetCompManualBound GetComponentWallBottomOffset SetCompInsertLoc SetComponentWallBottomOffset
GetCompMasterSnaps GetComponentWallTopOffset SetCompInsertLocOff SetComponentWallTopOffset
GetCompPenStylesN GetComponentWidth SetCompManualBound SetComponentWidth
GetCompSecFillChgPt GetComponents SetCompMasterSnaps SetCoreWallComponent
GetCompTopIsRelStory GetCoreWallComponent SetCompPenStylesN SetDatumRoofComp
GetCompUseClassASF GetDatumRoofComp SetCompSecFillChgPt SetDatumSlabComponent
GetCompUseClassASFCl GetDatumSlabComponent SetCompTopIsRelStory SetDefGenStoryBound
GetCompUseClassFCl GetDefGenStoryBound SetCompUseClassASF SetInsertLocComp
GetCompUseClassFill GetInsertLocComp SetCompUseClassASFCl SetObjectStoryBound
GetCompUseClassLPCl GetNumberOfComponents SetCompUseClassFCl SetRoofPrefStyle
GetCompUseClassLPS GetObjBoundElevation SetCompUseClassFill SetSlabHeight
GetCompUseClassLPW GetObjStoryBound SetCompUseClassLPCl SetSlabPreferencesStyle
GetCompUseClassRPCl GetObjStoryBoundsAt SetCompUseClassLPS SetSlabStyle
GetCompUseClassRPS GetObjStoryBoundsCnt SetCompUseClassLPW SetTaperedComponent
GetCompUseClassRPW GetRoofPrefStyle SetCompUseClassRPCl SlabFromPoly
GetCompWallAssBound GetRoofPreferences SetCompUseClassRPS SyncMatrixToBound

Objects - Custom

AddObjectTo2DComp GetHorizSecCPByStyle GetWallInsertLocOff SetHorizSecCutPlane
AddToPIOStyleEdit GetHorizSecCutPlane GetWallRecessGroup SetMirrorEmpty2DComp
CreateCustomObject GetLocalizedPluginChoice GetWllHoleObjIgnClsr SetMrEm2DCompByStyle
CreateCustomObjectN GetLocalizedPluginName GtExWllClsrFrmStBStl SetParamStyleType
CreateCustomObjectPath GetLocalizedPluginParameter HasPlugin SetParameterVisibility
CreateGroupOutline GetMirrorEmpty2DComp IsCatalogParameter SetPartDataID
DefineCustomObj GetMrEm2DCompByStyle IsNewCustomObject SetPartInstanceName
EnableParameter GetParamStyleType IsObjectTaggedAsPart SetPluginStyle
FlipHybMatrixObj GetPartDataID IsPluginFormat SetTopPlan2DComp
Generate2DFrom3DComp GetPartInstanceName NumCustomObjectChoices SetTpPl2DCompByStyle
Get2DCompByStyle GetPartTypeInfo RemovePIOStyleEdit SetUseWallClosure
Get2DCompLocation GetPartTypeName RemovePartTag SetUseWllClsrByStyle
Get2DComponentGroup GetPluginChoiceIndex SelectPluginCatalog SetVertSecCPByStyle
GetCatalogItem GetPluginInfo Set2DCompByStyle SetVertSecCutPlane
GetCatalogPath GetPluginString Set2DCompLocation SetWInsLocOffByStyle
GetClassByStyle GetPluginStyle Set2DComponentGroup SetWallClosureGroup
GetCustomFeedback GetPluginStyleSymbol SetAllStyleParams SetWallInsLocByStyle
GetCustomObjSecPath GetTopPlan2DComp SetClassByStyle SetWallInsertLoc
GetCustomObjectChoice GetTpPl2DCompByStyle SetCustomFeedback SetWallInsertLocOff
GetCustomObjectColor GetUseWallClosure SetCustomObjectColor SetWallRecessGroup
GetCustomObjectInfo GetUseWllClsrByStyle SetCustomObjectPath SetWllHoleObjIgnClsr
GetCustomObjectPath GetVertSecCPByStyle SetCustomObjectProfileGroup StExWllClsrFrmStBStl
GetCustomObjectProfileGroup GetVertSecCutPlane SetCustomObjectSelectionGroup TagSubObjectAsPart
GetCustomObjectSelectionGroup GetWInsLocOffByStyle SetCustomObjectWallHoleGroup UpdateStyledObjects
GetCustomObjectWallHoleGroup GetWallClosureGroup SetDisplayWith2DComp
GetDisplayWith2DComp GetWallInsLocByStyle SetExWllClsrFrmSt
GetExWllClsrFrmSt GetWallInsertLoc SetHorizSecCPByStyle

Objects - Groups

AddVPAnnotationObject GetVPClassVisibility Group SetVPCropObject
BeginGroup GetVPCropObject GroupToMesh SetVPLayerVisibility
BeginGroupN GetVPGroup HUngroup Ungroup
CreateVP GetVPGroupParent IsVPGroupContainedObject UpdateVP
EndGroup GetVPLayerVisibility SetVPClassVisibility VPHasCropObject

Objects - Lights

ContainsLight GetLightColorRGB GetSpreadAngle SetLightDirection
CreateLight GetLightDirection SetBeamAngle SetLightFalloff
GetBeamAngle GetLightFalloff SetLayerAmbientColor SetLightInfo
GetLayerAmbientColor GetLightInfo SetLayerAmbientInfo SetLightLocation
GetLayerAmbientInfo GetLightLocation SetLightColorRGB SetSpreadAngle

Objects - NURBS

ConvertToNURBS EvaluateNurbsSurfacePointAndNormal NurbsCurveType NurbsSetKnot
CreateInterpolatedSurface ExtendNurbsCurve NurbsDegree NurbsSetPt3D
CreateLoftSurfaces ExtendNurbsSurface NurbsDelVertex NurbsSetWeight
CreateNurbsCurve GetNurbsObjectDistanceFromPoint NurbsGetNumPts NurbsSurfaceEvalPt
CreateNurbsSurface GetParameterOnNurbsCurve NurbsGetPt3D RevolveWithRail
CreateOffsetNurbsObjectHandle GetPointAndParameterOnNurbsCurveAtGivenLength NurbsGetWeight TrimNurbsSurface
CreateSurfacefromCurvesNetwork NurbsCurveEvalPt NurbsKnot
DrawNurbsObject NurbsCurveGetNumPieces NurbsNumKnots

Objects - Polys

Add2DVertex DelVertex GetVertNum SetPolyPt
AddPoint EndPoly GetVertexVisibility SetPolylineVertex
ArcTo GetHole InsertVertex SetVertexVisibility
BeginPoly GetNumHoles IsPolyClosed Smooth
ClosePoly GetPolyPt OpenPoly
CurveThrough GetPolylineArcMaxRadius Poly
CurveTo GetPolylineVertex SetPolyClosed

Objects - Roofs

AppendRoofEdge GetBatAttributes GetRoofFaceCoords SetDormerThick
BeginRoof GetDormerAttributes GetRoofStyle SetGableAttributes
ConvToUnstyledRoof GetDormerThick GetRoofVertices SetHipAttributes
CreateBatDormer GetGableAttributes GetShedAttributes SetRoofAttributes
CreateGableDormer GetHipAttributes GetSkylight SetRoofEdge
CreateHipDormer GetNumRoofElements GetTrapeziumAttributes SetRoofStyle
CreateRoof GetRoofAttributes RemoveRoofEdge SetShedAttributes
CreateShedDormer GetRoofEdge RemoveRoofElement SetSkylight
CreateSkylight GetRoofElementType SetBatAttributes SetTrapeziumAttributes
CreateTrapeziumDormer GetRoofFaceAttrib SetDormerAttributes

Objects - Solids

AddSolid CreateCone IntersectSolid SubtractSolid
CalcSurfaceArea CreateHemisphere ObjSurfAreaInWorldC
CalcVolume CreateShell ObjSurfaceArea
CnvrtToGenericSolid CreateSphere ObjVolume

Objects - Stairs

StairGet2D3DCompType StairGetSideLengthsM StairSetConfigType StairSetTopGrUpFlMode
StairGetConfigType StairGetTopGrUpFlMode StairSetConstType StairSetTotalRiseM
StairGetConstType StairGetTotalRiseM StairSetNumRisers StairSetWFlight1M
StairGetNumRisers StairGetWFlight1M StairSetOptTotalRise
StairGetOptTotalRise StairSet2D3DCompType StairSetSideLengthsM

Objects - Symbols

ActSymDef GetSDName GetSymbolType SetSymbolOptionsN
ActSymDefN GetSymBrightMult InsertSymbolInFolder SymDefNum
AddToPluginStyle GetSymDefSubType RemoveFrmPluginStyle Symbol
BeginSym GetSymLoc3D SetActSymbol SymbolToGroup
CopySymbol GetSymName SetSymBrightMult
EndSym GetSymbolOptionsN SetSymDefSubType

Objects - Text

BeginText GetTextOrientation SetTextJust SetTextWrap
CreateText GetTextSize SetTextJustN TextFace
CreateTextStyleRes GetTextSpace SetTextLeading TextFlip
EndText GetTextStyle SetTextOrientation TextFont
GetCharColor GetTextStyleRef SetTextSize TextJust
GetFontID GetTextStyleRefN SetTextSpace TextLeading
GetFontListSize GetTextVerticalAlign SetTextStyle TextOrigin
GetFontName GetTextWidth SetTextStyleByClassN TextRotate
GetText GetTextWrap SetTextStyleRef TextSize
GetTextFont IsTextStyleByClassN SetTextStyleRefN TextSpace
GetTextJust SetText SetTextVertAlignN TextVerticalAlign
GetTextLeading SetTextAdorner SetTextVerticalAlign TrueTypeToPoly
GetTextLength SetTextFont SetTextWidth

Objects - Walls

AddCavity GetObjWallBreakMode GetWallWidth SetWallBelCutPlClass
AddSymToWall GetObjWallInsLocOff HWallHeight SetWallCapAttributesType
AddSymToWallEdge GetObjWallInsertMode HWallWidth SetWallCaps
AddWallBottomPeak GetObjectWallHeight InsertSymbol SetWallCapsOffsets
AddWallPeak GetObjectWallOffset IsCurtainWall SetWallControlOffset
BreakWall GetObjectWallPerpOff IsWallPeakTop SetWallCornerHeights
ClearCavities GetWallBelCutPlClass JoinWalls SetWallHeights
ClearWallPeaks GetWallCapAttributesType MoveWallByOffset SetWallOverallHeights
ConvertToUnstyledWall GetWallCaps ReverseWallSides SetWallStyle
CreateWallFeature GetWallCapsOffsets RoundWall SetWallThickness
CreateWallStyle GetWallCompEndPts SetCurtainWallCutPl SetWallWidth
DeleteWallPeak GetWallCompStartPts SetIsCurtainWall Wall
DeleteWallSym GetWallControlOffset SetLayerDeltaZOffset WallCap
GetCWFramesFromPt GetWallCornerHeights SetLinkHeightToLayerDeltaZ WallFootPrint
GetCWPanelFromPt GetWallHalfBreakInfo SetObjWallBreakMode WallHeight
GetCurtainWallCutPl GetWallOverallHeights SetObjWallInsLocOff WallPeak
GetLayerDeltaZOffset GetWallPathType SetObjWallInsertMode WallTo
GetLinkHeightToLayerDeltaZ GetWallPeak SetObjectAsCornerBreak WallWidth
GetNumOfWallBreaks GetWallPerpOffOfData SetObjectAsSpanBreak
GetNumWallPeaks GetWallStyle SetObjectWallHeight
GetObjExtentsInWall GetWallThickness SetObjectWallOffset

PDF

PDF_AnnotationsFromBlob PDF_FlushCache PDF_PrintBlob PDF_ThreadInitialize
PDF_CreateBlob PDF_GetNumOfAnnotations PDF_SetPageImage PDF_VerifyLibrary
PDF_CreatePDFABlobFromBlob PDF_GetPageCount PDF_SetProgressBar
PDF_DestroyBlob PDF_GetPageMatrixFromBlob PDF_SnapGeomFromBlob
PDF_DrawDCFromBlob PDF_GetPageSizeFromBlob PDF_ThreadDeInitialize

Parametric Constraints

BuildConstraintModelForObject GetBinaryConstraint HasConstraint SetConstraintValue
DeleteConstraint GetSingularConstraint SetBinaryConstraint SetSingularConstraint

PlantObjectCoreTools

Plant_CreateDupPlant Plant_GetToolPlantNm Plant_ReplacePlant Plant_UpdatePlaceTool
Plant_EditPlantDefRB Plant_GetToolPlcMode Plant_ReplacePlantParam Plant_UpdateTranslat
Plant_GetToolInit Plant_GetToolSpacing Plant_ResetPlantInst

Project Sharing

GetCheckoutsComment GetProjectFullPath GetProjectUserNames IsProjectOffline
GetCurrentUserId GetProjectName GetWorkingFileId SetCheckoutsComment
GetLayerProjectInfo GetProjectUser IsAWorkingFile

Protection

Prot_DisableModule Prot_GetLicenseID Prot_GetSeatsNum Prot_IsFundamentals
Prot_GetDistribCode Prot_GetLicenseType Prot_GetUsedSeatsNum Prot_IsModuleEnabled

Roadway Interface Library

Road_GetStationCount Road_GetStationPoint Road_InsertStation

Selection

DSelectAll NumSelectedObjects Selected SetSelect
NumSObj SelectAll SetDSelect

SiteModel Interface Library

DTM6_ClearModelCache DTM6_IsObjectReady DTM6_ShowSendEdgeDlg SetFenceAttrs
DTM6_GetDTMObject DTM6_IsTypeVisible DegFromStr SetPadAttrs
DTM6_GetDTMOver DTM6_RestoreDefaults MakeModifierClass
DTM6_GetZatXY DTM6_RiseToSurface PercStrFromDeg
DTM6_IsDTM6Object DTM6_SendToSurface RiseRunFromDeg

SpaceObjectCoreTools

Space_AddAreaModifierToSpace Space_CountAssignedZones Space_GetGrossVolume Space_ItemAvailableZones
Space_AddDiscription Space_CountAvailableZones Space_GetNetArea Space_Net3DBoundary
Space_AddName Space_CreateSpace Space_GetNetPoly Space_RenameAssignedZoneX
Space_AddRoomID Space_DeassignZone Space_GetNetVolume Space_Set3DGrossHeightOffset
Space_AddZone Space_GetGrossArea Space_Gross3DBoundary Space_Set3DGrossHeightOffset1
Space_AssignZone Space_GetGrossPoly Space_ItemAssignedZones Space_Set3DNetHeightOffset

Special - QuickTime

QTCloseMovieFile QTGetMovieOptions QTOpenMovieFile QTSetMovieOptionsN
QTCloseMovieFileN QTGetMovieOptionsN QTOpenMovieFileN QTTerminate
QTCreateMovieRefID QTInitialize QTSetMovieOptions QTWriteFrame

Spotlight

AdditionalDefRecords DBeam_SetBShutDepth HO_GetHoistOriginAt LDevice_SetAccPos2D
ApplyLightInfoRecord DBeam_SetBeamAngle HO_GetNumHoistOrigin LDevice_SetAccPos3D
DBeam_Begin DBeam_SetBeamAngle2 LDevice_AddAccessory LDevice_SetParamBool
DBeam_BeginShttGet DBeam_SetFallOffDist LDevice_DeleteAcc LDevice_SetParamLong
DBeam_End DBeam_SetFocusPoint LDevice_DlgResource LDevice_SetParamReal
DBeam_EndShttGet DBeam_SetLShutAngle LDevice_GetAccCount LDevice_SetParamStr
DBeam_Get2DLines DBeam_SetLShutDepth LDevice_GetAccPos2D LightingInvExport
DBeam_Get2DLn2FOff DBeam_SetLampRot LDevice_GetAccPos3D LightingInvImport
DBeam_Get2DObjAtFs DBeam_SetLightOrigin LDevice_GetActSym LightingUnivExport
DBeam_Get2DObjFOff DBeam_SetRShutAngle LDevice_GetCellCount LightingUnivImport
DBeam_Get3DShutter DBeam_SetRShutDepth LDevice_GetParamBool SL_Export
DBeam_GetLast2DObj DBeam_SetShow3DType LDevice_GetParamLong SL_Import
DBeam_GetLastObject DBeam_SetShowAtPoint LDevice_GetParamReal SL_UpdateSAcc
DBeam_GetLines DBeam_SetTShutAngle LDevice_GetParamStr SL_UpdateUID
DBeam_GetLines2FOff DBeam_SetTShutDepth LDevice_ReleaseRes SetVisionMapping
DBeam_GetObjAtFocus DBeam_ShowBeamLines LDevice_Reset
DBeam_GetObjFallOff GetVisionMapping LDevice_ResetVisual
DBeam_SetBShutAngle HO_GetHoistColorLbl LDevice_SetAccCell

Strings

Angle2Str GetResourceString Num2StrF Str2Volume
Area2Str GetVWRString Ord SubString
Chr Insert Pos UniChr
Concat Len Str2Angle UprString
Copy LenEncoding Str2Area Volume2Str
Delete Num2Str Str2Num

Textures

AddCustomTexPart GetTexBFeatureEnd GetTextureShininess SetTexBitRepVert
ApplyCustomTexPart GetTexBFeatureStart GetTextureSize SetTexBitmapOrigin
AttachDefaultTextureSpace GetTexBitFeatureSize GetTextureSpace SetTexMapBool
CreatePaintFromImage GetTexBitPaintNode GetTextureTransp SetTexMapBoolN
CreatePaintFromImgN GetTexBitRepHoriz GetWallHoleTexturePart SetTexMapInt
CreateShaderRecord GetTexBitRepVert IsImageCropVisible SetTexMapIntN
CreateTexture GetTexBitmapOrigin IsImageCropped SetTexMapReal
CreateTextureBitmap GetTexMapBool IsRW SetTexMapRealN
CreateTextureBitmapD GetTexMapBoolN IsTextureableObject SetTexSpace2DOffset
CreateTextureBitmapN GetTexMapInt RemoveCustomTexParts SetTexSpace2DRadius
CustomTexPartExists GetTexMapIntN ResolveByClassTextureRef SetTexSpace2DRot
DeleteTextureSpace GetTexMapReal SetClTextureC SetTexSpace2DScale
EditShaderRecord GetTexMapRealN SetClTextureD SetTexSpaceEndCap
EditTexture GetTexSpace2DOffset SetClTextureG SetTexSpaceKind
EditTextureBitmap GetTexSpace2DRadius SetClTextureL SetTexSpaceOrientU
EditTextureSpace GetTexSpace2DRot SetClTextureR SetTexSpaceOrientV
GS_EdSh_ConstructLayout GetTexSpace2DScale SetClTextureT SetTexSpaceOrientW
GS_EdSh_PopulateMenu GetTexSpaceEndCap SetCustomRWPrefs SetTexSpaceOrigin
GS_EdSh_RunDialog GetTexSpaceKind SetDefaultTexMap SetTexSpacePartID
GetClTextureC GetTexSpaceOrientU SetDefaultTexMapN SetTexSpaceStartCap
GetClTextureD GetTexSpaceOrientV SetDefaultTextureSpace SetTextureBitmap
GetClTextureG GetTexSpaceOrientW SetImageCropObject SetTextureRef
GetClTextureL GetTexSpaceOrigin SetImageCropVisible SetTextureRefN
GetClTextureR GetTexSpacePartID SetObjExpandTexture SetTextureSet
GetClTextureT GetTexSpaceStartCap SetOpenGLPrefs SetTextureShader
GetClUseTexture GetTextureBitmap SetTexBFeatureEnd SetTextureShininess
GetImageCropObject GetTextureRef SetTexBFeatureStart SetTextureSize
GetNumTexLayers GetTextureRefN SetTexBitFeatureSize SetTextureTransp
GetObjExpandTexture GetTextureSet SetTexBitPaintNode SetWallHoleTexturePart
GetShaderRecord GetTextureShader SetTexBitRepHoriz

Tool Events

ResList_DlgInit vstDrawCoordLineN vstGetModeValue vstSetDataLong
vstAddButtonMode vstDrawCoordLineN3D vstGetPickObject vstSetDataReal
vstAddPDMenuItem vstDrawCoordRect vstGetPt2D vstSetDataString
vstAddPDMenuMode vstEnableMode vstGetPt3D vstSetEventInfo
vstAddRadioMode vstGetCurrPt2D vstGetRsrcFileID vstSetEventResult
vstAddResPDMenuMode vstGetCurrPt3D vstGetString vstSetHelpString
vstCustomProcNNA vstGetDataLong vstGetToolObject vstSetModeHelpBase
vstDefault2DToolDraw vstGetDataReal vstNameUndoEvent vstSetPDMenuSel
vstDefault3DToolDraw vstGetDataString vstNumPts vstSetPtBehavior
vstDrawCoordArcN vstGetEventInfo vstResPDMenuInit vstSetRsrcFile
vstDrawCoordEllipse vstGetEventResult vstRestoreWPHybridTool vstSetWPHybridTool
vstDrawCoordLine vstGetInitObject vstSetCursorByView
vstDrawCoordLine3D vstGetModeHelpBase vstSetCustomProc

Truss Analysis

DLDBeginLoadData OLDConstructMatsCnt OLDGetLoadDataBool OLDMassStrToReal
DLDEndLoadData OLDFindAttachHangPos OLDGetLoadDataReal OLDSelectTrussSystem
DLDSetLoadDataBool OLDForceRealToStr OLDGetLoadDataStr OLDSetHangPathHandle
DLDSetLoadDataReal OLDForceStrToReal OLDGetMatDensity OLDSetLoadDataBool
DLDSetLoadDataString OLDGetConstructMat OLDGetPositionTransf OLDSetLoadDataReal
HP_AutoAttachLoads OLDGetDragSnapPoint OLDHoistSectionDlg OLDSetLoadDataStr
HP_ConvertToHangPos OLDGetHangPointAt OLDMassDistRealToStr OLDShowTrussSnapping
OLDAddLoadHangPoint OLDGetHangPointsCnt OLDMassDistStrToReal OLDTrussSectionDlg
OLDClearHangPtsPath OLDGetHangingPos OLDMassRealToStr UpdatePositionParam

Units

GetPrimaryUnitInfo GetSecondaryUnitInfo PrimaryUnits Units
GetRoundingBase GetUnits SecondaryUnits

User Interactive

AutoKey GetLine GetRect SetModeButtonText
BeginModeButtonsText GetLine3D GetRect3D SetTempToolHelpStr
CallTool GetMouse KeyDown SetToolHelpMessage
CapsLock GetPt MouseDown Shift
Command GetPt3D Option TrackObject
EndModeButtonsText GetPtL RunTempTool TrackObjectN
GetKeyDown GetPtL3D SetCursor

Utility

BeginContext GetDashFromPseudoInd PlanarPtTo3DModelPt Rpstr_SetValueStr
BeginMultDashConvert GetEnabledModules PlanarPtToScreenPlanePt RunImageComp
CallToolByIndex GetMainDisplayBounds PrepRelatedObjectForChange ScreenPlanePtToPlanarPt
CallToolByName GetNetAdapterInfo ProgressDlgClose SetCallBackInval
CallToolWithMode GetOSVersion ProgressDlgEnd SetCurrentObject
ClrMessage GetPaletteVisibility ProgressDlgHasCancel SetDrawingRect
ColorIndexToRGB GetPickObjectInfo ProgressDlgOpen SetMaximumUndoEvents
ColorIndexToRGBN GetPlantToolInitialized ProgressDlgOpenDelay SetModeString
CreateUUID GetPlantToolPlacementMode ProgressDlgSetBotMsg SetPaletteVisibility
Date GetPlantToolPlantName ProgressDlgSetMeter SetPlanarTransform
DelSavedSetting GetPlantToolSpacing ProgressDlgSetTopMsg SetSavedSetting
DelSavedSettings GetProduct ProgressDlgStart SetToolByIndex
DisableModules GetPseudoIndFromDash ProgressDlgYield SetToolByName
DisplayContextHelpOfCurrentPlugin GetSavedSetting PythonBeginContext SetToolWithMode
DisplayContextualHelp GetScreen PythonEndContext SetWorkingPlane
DisplayOrganizationDialog GetTickCount PythonExecute SetWorkingPlaneN
EditCriteriaWithUI GetVersion PythonGetSearchPath ShowWebDlg
EncryptAllPlugins GetVersionEx PythonSetSearchPath SortArray
EncryptPlugin GetWorkingPlane RGBToColorIndex SysBeep
EndContext GetWorkingPlaneMat RGBToColorIndexN TBB_AttachRecords
EndMultDashConvert GetWorkingPlaneN ReDraw TBB_GetPageArea
ExportImageFile ImportImageFile ReDrawAll TBB_OpenTBBSelDlg
FndError ImportImageFileN RedrawSelection TBB_UpdateOldBorders
ForEachObjectAtPoint InstallScriptAddPath ResetObject TBB_UpdateOldVAATB
ForEachObjectInLayer IsCoPlanar Rpstr_GetValueBool TestEncryptPlugins
ForEachObjectInList IsPerpPlane Rpstr_GetValueInt UndoOff
GetActiveSerialNumber LandmarkMatchSlope Rpstr_GetValueReal UpdatePIOFromStyle
GetArrayDimensions Message Rpstr_GetValueStr ValidAngStr
GetCallBackInval NameUndoEvent Rpstr_RemoveValue ValidNumStr
GetClosestPt ObjPropsEditDlg Rpstr_RemoveValues VerifyLibraryRoutine
GetClosestSide OpenScriptResPal Rpstr_SetValueBool Wait
GetCurrentLocalization OpenURL Rpstr_SetValueInt WebDlgEnableConsole
GetCurrentMode PickObject Rpstr_SetValueReal

View / Zoom

CreateHLHandle GetHLLineStyle RetrieveCustomRWPrefs SetView
CreateOpenGLHandle GetProjection RetrieveHLPrefs SetViewVector
CreateRWHandle GetVCenter RetrieveOpenGLPrefs SetZoom
CreateRenderworksStyle GetView SaveSheet VDelete
EditOpenGLPrefs GetZoom SetHLLineStyle VRestore
EditRenderWorksPrefs Projection SetVCenter VSave

Viewports

CreateVPClOvrd GetVPClOvrdPenBack GetVPLrOvrdPenFore SetVPClOvrdPenFore
CreateVPLrOvrd GetVPClOvrdPenFore RemoveVPClOvrd SetVPClOvrdPenOpty
GetVPClOvrdCount GetVPClOvrdPenOpty RemoveVPLrOvrd SetVPClOvrdRoofTxt
GetVPClOvrdFillBack GetVPClOvrdRoofTxt SetVPClOvrdFillBack SetVPClOvrdWallTxt
GetVPClOvrdFillFore GetVPClOvrdWallTxt SetVPClOvrdFillFore SetVPLrOvrdFillBack
GetVPClOvrdFillOpty GetVPLrOvrdCount SetVPClOvrdFillOpty SetVPLrOvrdFillFore
GetVPClOvrdFillStyle GetVPLrOvrdFillBack SetVPClOvrdFillStyle SetVPLrOvrdOpty
GetVPClOvrdLineStyle GetVPLrOvrdFillFore SetVPClOvrdLineStyle SetVPLrOvrdPenBack
GetVPClOvrdLnWeight GetVPLrOvrdHandle SetVPClOvrdLnWeight SetVPLrOvrdPenFore
GetVPClOvrdName GetVPLrOvrdOpty SetVPClOvrdObjTxt
GetVPClOvrdObjTxt GetVPLrOvrdPenBack SetVPClOvrdPenBack

Worksheets

ActSSheet GetWSColumnWidth IsWSVisible SetWSCurrentCell
AddWSColumnOperator GetWSFromImage LoadCell SetWSImageScaleF
AreWorksheetGridLinesVisible GetWSImage MoveWSColumnOperator SetWSImgAngle
AutoFitWSRowHeights GetWSImageScaleF NewSprdSheet SetWSImgComponent
CellHasNum GetWSImgAngle RecalculateWS SetWSImgMarginSize
CellHasStr GetWSImgComponent RemoveAllWSColumnOperators SetWSImgRenderMode
CellString GetWSImgMarginSize RemoveWSColumnOperator SetWSImgScale
CellValue GetWSImgRenderMode SelectSS SetWSImgShowDBHeader
ClearWSCell GetWSImgScale SetSprdSortSum SetWSImgSize
CloseSS GetWSImgShowDBHeader SetSprdSortSumColumns SetWSImgSizeType
CreateWS GetWSImgSize SetTopVisibleWS SetWSImgType
CreateWSImage GetWSImgSizeType SetWSAutoRecalcState SetWSImgUseLayScale
DeleteWSColumns GetWSImgType SetWSCellAlignment SetWSImgUseObjectImg
DeleteWSRows GetWSImgUseLayScale SetWSCellBorder SetWSImgView
EnableDrawingWorksheetPalette GetWSImgUseObjectImg SetWSCellBorders SetWSPlacement
GetCAlign GetWSImgView SetWSCellBottomBN SetWSRowHeight
GetCWidth GetWSMergedCellRange SetWSCellBottomBorder SetWSSelection
GetCellNum GetWSPlacement SetWSCellFill SetWSTextAngle
GetCellStr GetWSRowColumnCount SetWSCellFormula SetWorksheetGridLinesVisibility
GetSprdSortSum GetWSRowHLockState SetWSCellFormulaN ShowWS
GetSprdSortSumColumns GetWSRowHeight SetWSCellInsideHorizBorder ShowWSDialog
GetTopVisibleWS GetWSSelection SetWSCellInsideHzBN SprdAlign
GetWSAutoRecalcState GetWSSubrowActualCellString SetWSCellInsideVertBorder SprdBorder
GetWSCellAlignment GetWSSubrowActualStringN SetWSCellInsideVtBN SprdFormat
GetWSCellBorder GetWSSubrowCellStrN SetWSCellLeftBN SprdSize
GetWSCellFill GetWSSubrowCellString SetWSCellLeftBorder SprdWidth
GetWSCellFormula GetWSSubrowCellValue SetWSCellNumberFormat TargetSprdSheet
GetWSCellFormulaN GetWSSubrowCount SetWSCellOutlineBN WSScript_AddHandle
GetWSCellNumberFormat GetWSSubrowHeight SetWSCellOutlineBorder WSScript_AddHandleId
GetWSCellString HasWSColumnOperator SetWSCellRightBN WSScript_GetEdit
GetWSCellStringN InsertWSColumns SetWSCellRightBorder WSScript_GetEditObj
GetWSCellTextAngle InsertWSRows SetWSCellTextColor WSScript_GetObject
GetWSCellTextColor IsValidWSCell SetWSCellTextFormat WSScript_GetPrmInt
GetWSCellTextFormat IsValidWSRange SetWSCellTopBN WSScript_GetPrmReal
GetWSCellValue IsValidWSSubrowCell SetWSCellTopBorder WSScript_GetPrmStr
GetWSCellVertAlignment IsWSCellNumber SetWSCellVertAlignment WSScript_SetResImage
GetWSCellWrapTextFlag IsWSCellString SetWSCellWrapTextFlag WSScript_SetResInt
GetWSCellsImgDPIRes IsWSDatabaseRow SetWSCellsImgDPIRes WSScript_SetResReal
GetWSColumnOperators IsWSImg SetWSColumnOperators WSScript_SetResStr
GetWSColumnSortPrecedence IsWSSubrowCellNumber SetWSColumnSortType WorksheetMergeCells
GetWSColumnSortType IsWSSubrowCellString SetWSColumnWidth WorksheetSplitCells

Workspaces

ws2AddMenuGroup ws2DelMenuAt ws2GetToolAt wsEditAddTool
ws2AddMenuItem ws2DelTool ws2GetToolInfo wsEditAddTool2
ws2CommitChanges ws2FindMenuIndex ws2GetToolsCnt wsEditBegin
ws2CreateTool ws2FindToolIndex ws2SetMenuInfo wsEditBeginN
ws2CreateToolPalette ws2GetMenuAt ws2SetToolInfo wsEditEnd
ws2CreateToolSet ws2GetMenuInfo wsDelete wsInstallCanceled
ws2DelMenu ws2GetMenusCnt wsEditAddMenu wsInstallFailed

XML

CreateNewXMLDocument GetAttributeValue InitXML SetElementValue
DeleteAttribute GetCDATA ReadXMLFile WriteXMLFile
DeleteCDATA GetElementValue ReadXMLMemory WriteXMLMemory
DeleteElement GetFirstChild ReleaseXML
FindAttribute GetNextElement SetAttributeValue
FindElement GetPreviousElement SetCDATA

XML SAX

XMLSAXAddNodeAttr XMLSAXBeginDocMemory XMLSAXEndDocMemory XMLSAXParseMemory
XMLSAXAddNodeValue XMLSAXBeginNode XMLSAXEndNode
XMLSAXBeginDocFile XMLSAXEndDoc XMLSAXParseFile