VS:GetLBItemMkrChoice

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified list browser item's marker.

PROCEDURE GetLBItemMkrChoice(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
VAR style :LONGINT;
VAR angle :INTEGER;
VAR size :REAL;
VAR width :REAL;
VAR thicknessBasis :INTEGER;
VAR thickness :REAL);
def vs.GetLBItemMkrChoice(dialogID, componentID, itemIndex, subItemIndex):
    return (BOOLEAN, style, angle, size, width, thicknessBasis, thickness)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
style LONGINT the marker's style
angle INTEGER the marker's angle
size REAL the marker's size
width REAL the marker's width
thicknessBasis INTEGER the marker's thickness basis
thickness REAL the marker's thickness

Version

Availability: from Vectorworks 2022