VS:SetLBResOnlyCurDoc

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified list browser item to only use the current document when using/displaying resources.

PROCEDURE SetLBResOnlyCurDoc(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
onlyCurrentDoc :BOOLEAN);
def vs.SetLBResOnlyCurDoc(dialogID, componentID, itemIndex, subItemIndex, onlyCurrentDoc):
    return None

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the item index
subItemIndex INTEGER the column index
onlyCurrentDoc BOOLEAN specifies whether or not only the current document should be used

Version

Availability: from Vectorworks 2022