VS:vstGetModeValue

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the value of the specified mode. Different mode types return values as follows:

  • radio button: Returns the number of the currently selected radio button (numbered left to right starting at 1.)
  • checkbox: Returns 1 if the checkbox is checked, 0 if it is not.
  • button: Always returns 0.
PROCEDURE vstGetModeValue(
inModeGroup :LONGINT;
VAR outValue :LONGINT);
def vs.vstGetModeValue(inModeGroup):
    return outValue

Parameters

inModeGroup LONGINT
outValue LONGINT Output parameter.

Version

Availability: from All Versions

This is drop-in function.