VS:IFC GetDSFieldInfoAt

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets label, visibility state, by formula state for Data Sheet field.

FUNCTION IFC_GetDSFieldInfoAt(
objectName :STRING;
dataSheetName :STRING;
iField :INTEGER;
VAR outFieldLabel :STRING;
VAR outIsVisible :BOOLEAN;
VAR outIsByFormula :BOOLEAN) : BOOLEAN;
def vs.IFC_GetDSFieldInfoAt(objectName, dataSheetName, iField):
    return (BOOLEAN, outFieldLabel, outIsVisible, outIsByFormula)

Parameters

objectName STRING
dataSheetName STRING
iField INTEGER
outFieldLabel STRING
outIsVisible BOOLEAN
outIsByFormula BOOLEAN

Version

Availability: from Vectorworks 2023.4