VS:RunNamedDialog

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays the specified dialog with universal name and initiates the dialog event loop. The dialog event loop is specified in a procedure subroutine that is passed as a parameter to the function.

FUNCTION RunNamedDialog(
dialogID :LONGINT;
callback :PROCEDURE;
univName :STRING) : LONGINT;
def vs.RunNamedDialog(dialogID, callback, univName):
    return LONGINT

Parameters

dialogID LONGINT The index of the dialog to be displayed
callback PROCEDURE The event loop subroutine for the dialog
univName STRING The universal name of the dialog

Return Value

Returns a LONGINT value indicating the button pressed to exit the dialog.

Remarks

[DWD 1/29/13]

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:RunLayoutDialog

VS Functions: [[VS:RunLayoutDialog]]