VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Inherit VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette

Interface

class IWorkspaceToolPalette : public IWorkspaceSizeablePalette
{
public:
  virtual VCOMError VCOM_CALLTYPE SetDisplayName(const TXString& inName) = 0;
  virtual VCOMError VCOM_CALLTYPE GetDisplayName(TXString& outName) = 0;
  virtual VCOMError VCOM_CALLTYPE AddToolSet(IWorkspaceToolSet* inToolSet) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolSetCount(Sint16& outToolSetCount) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolSetAtIndex(Sint16 inIndex, IWorkspaceToolSet** outToolSet) = 0;
  virtual VCOMError VCOM_CALLTYPE SetToolSetViewStyle(Sint16 inViewStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolSetViewStyle(Sint16& outViewStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE SetToolSetSortStyle(Sint16 inSortStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolSetSortStyle(Sint16& outSortStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE SetToolViewStyle(Sint16 inViewStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolViewStyle(Sint16& outViewStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE SetToolSortStyle(Sint16 inSortStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolSortStyle(Sint16& outSortStyle) = 0;
  virtual VCOMError VCOM_CALLTYPE SetToolSetPosition(bool inTopPosition) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolSetPosition(bool& outToolSetPosition) = 0;
  virtual VCOMError VCOM_CALLTYPE SetActiveToolSet(Sint16 inToolSetIndex) = 0;
  virtual VCOMError VCOM_CALLTYPE GetActiveToolSet(Sint16& outActiveToolSetIndex) = 0;
  virtual VCOMError VCOM_CALLTYPE SetTearOffState(bool inTearOffState) = 0;
  virtual VCOMError VCOM_CALLTYPE GetTearOffState(bool& outTearOffState) = 0;
  virtual VCOMError VCOM_CALLTYPE GetLastError(EWorkspacesError& outError) = 0;
};

Members

SetDisplayName Sets the display name for the tool palette.
GetDisplayName Gets the display name for the tool palette.
AddToolSet Adds a tool set to this tool palette.
GetToolSetCount Get the number of tool sets that are in the tool palette.
GetToolSetAtIndex Gets the tool set at the given index.
SetToolSetViewStyle Sets the view style for the tool sets.
GetToolSetViewStyle Gets the view style for the tool sets.
SetToolSetSortStyle Sets the sort style for the tool sets
GetToolSetSortStyle Gets the current sort style used for the tools.
SetToolViewStyle Sets the view style for the tool sets.
GetToolViewStyle Gets the view style for the tools.
SetToolSortStyle Sets the sort style for the tools.
GetToolSortStyle Gets the current sort style used for the tools.
SetToolSetPosition The position of the group of tool sets in the tool palette.
GetToolSetPosition The position of the group of tool sets in the tool palette.
SetActiveToolSet Sets the active tool set by its index.
GetActiveToolSet Gets the active tool set for this tool palette.
SetTearOffState Sets the status flag that indicates whether or not this is a tear-off tool palette.
GetTearOffState Gets the status flag that indicates whether or not this is a tear-off tool palette.
GetLastError Gets the last error that was generated by the IWorkspaces interface.

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Workspaces:IWorkspaces

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Workspaces:IWorkspaces]]