VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::GetToolSetCount

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

Get the number of tool sets that are in the tool palette.

virtual VCOMError VCOM_CALLTYPE GetToolSetCount(
Sint16& outToolSetCount) = 0;

Parameters

outToolSetCount Sint16& on output, if successful, the count of tool sets in the tool palette.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.