VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::SetActiveToolSet

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

Sets the active tool set by its index.

virtual VCOMError VCOM_CALLTYPE SetActiveToolSet(
Sint16 inToolSetIndex) = 0;

Parameters

inToolSetIndex Sint16 the index of the tool set that is to be active for the given tool palette.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.