VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::GetToolSetPosition

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

The position of the group of tool sets in the tool palette.

virtual VCOMError VCOM_CALLTYPE GetToolSetPosition(
bool& outToolSetPosition) = 0;

Parameters

outToolSetPosition bool& on output, if successful, true if the tool sets should be grouped at the top of the tool palette, false for the bottom of the tool palette.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.