VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::GetToolViewStyle

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

Gets the view style for the tools (icon, icon & text, text)

virtual VCOMError VCOM_CALLTYPE GetToolViewStyle(
Sint16& outViewStyle) = 0;

Parameters

outViewStyle Sint16& Output parameter. Return the number representing the enumeration of the view style enumeration.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.