VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

interit VCOM:VectorWorks:Workspaces:IWorkspacePalette

This class handles the workspace settings for resizable palettes.

Interface

class IWorkspaceSizeablePalette : public IWorkspacePalette
{
public:
  virtual VCOMError VCOM_CALLTYPE SetDimensions(Sint16 inWidth, Sint16 inHeight) = 0;
  virtual VCOMError VCOM_CALLTYPE GetDimensions(Sint16& outWidth, Sint16& outHeight) = 0;
};

Members

SetDimensions Sets the width and height for the palette.
GetDimensions Gets the width and height for the palette.

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Workspaces:IWorkspaces

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Workspaces:IWorkspaces]]