VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::SetToolSetPosition

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

The position of the group of tool sets in the tool palette.

virtual VCOMError VCOM_CALLTYPE SetToolSetPosition(
bool inTopPosition) = 0;

Parameters

inTopPosition bool true if we want this palette to display its group of tool sets at the top of the palette. False if it should be at the bottom.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.