VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Interface

class IWorkspaceToolSet : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE GetIdentifier(TXString& outIdentifier) = 0;
  virtual VCOMError VCOM_CALLTYPE SetDisplayName(const TXString& inName) = 0;
  virtual VCOMError VCOM_CALLTYPE GetDisplayName(TXString& outName) = 0;
  virtual VCOMError VCOM_CALLTYPE SetIcon(Uint8* inIconData, Uint32 inIconDataSize) = 0;
  virtual VCOMError VCOM_CALLTYPE GetIcon(Uint8*& inIconData, Uint32& inIconDataSize) = 0;
  virtual VCOMError VCOM_CALLTYPE AddTool(IWorkspaceTool* inTool) = 0;
  virtual VCOMError VCOM_CALLTYPE AddChildTool(IWorkspaceTool* inParentTool, IWorkspaceTool* inChildTool) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolCount(Sint16& outToolCount) = 0;
  virtual VCOMError VCOM_CALLTYPE GetToolAtIndex(Sint16 inIndex, IWorkspaceTool** outTool, bool& outHasSubTools) = 0;
  virtual VCOMError VCOM_CALLTYPE GetSubToolCountForTool(IWorkspaceTool* inParentTool, Sint16& outSubToolCount) = 0;
  virtual VCOMError VCOM_CALLTYPE GetSubToolForToolAtIndex(IWorkspaceTool* inParentTool, Sint16 inIndex, IWorkspaceTool** outChildTool) = 0;
  virtual VCOMError VCOM_CALLTYPE GetLastError(EWorkspacesError& outError) = 0;
};

Members

GetIdentifier Gets the workspace identifier for the menu item.
SetDisplayName Sets the display name for the tool palette.
GetDisplayName Gets the display name for the tool set.
SetIcon Sets the tool set icon.
GetIcon Gets the tool set icon.
AddTool Adds a new tool to this tool set.
AddChildTool Adds a Sub-Tool to the given tool in the tool set.
GetToolCount Gets the number of tool buttons for this tool set.
GetToolAtIndex Gets the tool at the given index.
GetSubToolCountForTool Gets the number of sub-tools for the given tool.
GetSubToolForToolAtIndex Gets the sub-tool for the given parent tool at the given index.
GetLastError Gets the last error that was generated by the IWorkspaces interface.

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Workspaces:IWorkspaces

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Workspaces:IWorkspaces]]