VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::SetIcon

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Sets the tool set icon.

virtual VCOMError VCOM_CALLTYPE SetIcon(
Uint8* inIconData,
Uint32 inIconDataSize) = 0;

Parameters

inIconData Uint8* a memory pointer which contains data necessary to draw an Icon.
inIconDataSize Uint32 the size of memory allocated for the icon.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.