VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::GetIcon

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Gets the tool set icon.

virtual VCOMError VCOM_CALLTYPE GetIcon(
Uint8*& inIconData,
Uint32& inIconDataSize) = 0;

Parameters

inIconData Uint8*& on output, if successful, a memory pointer which contains data necessary to draw an Icon. Client must GS_Dispose this memory.
inIconDataSize Uint32& on output, if successful, the size of memory allocated for the icon.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.