VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::GetSubToolCountForTool

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Gets the number of sub-tools for the given tool.

virtual VCOMError VCOM_CALLTYPE GetSubToolCountForTool(
IWorkspaceTool* inParentTool,
Sint16& outSubToolCount) = 0;

Parameters

inParentTool IWorkspaceTool* the tool that will be the tool button for this tool set.
outSubToolCount Sint16& on output, if successful, the number of sub-tools in the parent tool.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.