VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::GetToolAtIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Gets the tool at the given index.

virtual VCOMError VCOM_CALLTYPE GetToolAtIndex(
Sint16 inIndex,
IWorkspaceTool** outTool,
bool& outHasSubTools) = 0;

Parameters

inIndex Sint16 the index into the list of buttons to retrieve the tool for.
outTool IWorkspaceTool** on output, if successful, the tool stored at the given index.
outHasSubTools bool& on output, if successful, a bool that indicates whether or not this tool button has sub-tools.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.