VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::SetDisplayName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Sets the display name for the tool palette.

virtual VCOMError VCOM_CALLTYPE SetDisplayName(
const TXString& inName) = 0;

Parameters

inName const TXString& the display name that this tool palette should use.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.