VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette::SetDimensions

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette

Sets the width and height for the palette.

virtual VCOMError VCOM_CALLTYPE SetDimensions(
Sint16 inWidth,
Sint16 inHeight) = 0;

Parameters

inWidth Sint16 the width to set for this palette.
inHeight Sint16 the height to set for this palette.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.