VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette::GetDimensions

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette

Gets the width and height for the palette.

virtual VCOMError VCOM_CALLTYPE GetDimensions(
Sint16& outWidth,
Sint16& outHeight) = 0;

Parameters

outWidth Sint16& Output parameter. Return the current width of the palette.
outHeight Sint16& Output parameter. Return the current height of the palette.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.