VCOM:VectorWorks:Workspaces:IWorkspacePalette

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Interface

class IWorkspacePalette : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE GetIdentifier(TXString& outIdentifier) = 0;
  virtual VCOMError VCOM_CALLTYPE SetHomeCorner(EWindowHomeCorner inHomeCorner) = 0;
  virtual VCOMError VCOM_CALLTYPE GetHomeCorner(EWindowHomeCorner& outHomeCorner) = 0;
  virtual VCOMError VCOM_CALLTYPE SetHomeCornerOffset(Sint16 inHorizontalOffset, Sint16 inVerticalOffset) = 0;
  virtual VCOMError VCOM_CALLTYPE GetHomeCornerOffset(Sint16& outHorizontalOffset, Sint16& outVerticalOffset) = 0;
  virtual VCOMError VCOM_CALLTYPE SetWindowShadeState(bool inWindowShadeState) = 0;
  virtual VCOMError VCOM_CALLTYPE GetWindowShadeState(bool& outWindowShadeState) = 0;
  virtual VCOMError VCOM_CALLTYPE SetVisibilityState(bool inVisibilityeState) = 0;
  virtual VCOMError VCOM_CALLTYPE GetVisibilityState(bool& outVisibilityeState) = 0;
  virtual VCOMError VCOM_CALLTYPE GetLastError(EWorkspacesError& outError) = 0;
};

Members

GetIdentifier Gets the workspace identifier for the menu item.
SetHomeCorner Sets the palette's home corner.
GetHomeCorner Gets the palette's home corner.
SetHomeCornerOffset Sets the offset from the palette's home corner.
GetHomeCornerOffset Sets the offset from the palette's home corner.
SetWindowShadeState Sets the window shade state for the given palette.
GetWindowShadeState Gets the Window Shade state for the palette.
SetVisibilityState Gets the visibility state for the palette.
GetVisibilityState Gets the visibility state of the palette.
GetLastError Gets the last error that was generated by the IWorkspaces interface.

Remarks

EWindowCorner is the corner from where a Window's offset is calculated from.

For example, if a Window's home corner is the Upper Right, and the Window has an offset of (10, 20), the Window is offset 10 pixels to the left of the right hand side of the display and 20 pixels down from the top side of the display.

enum EWindowHomeCorner {
  eWindowHomeCorner_UpperLeft,
  eWindowHomeCorner_UpperRight,
  eWindowHomeCorner_LowerRight,
  eWindowHomeCorner_LowerLeft,
  eWindowHomeCorner_ScreenUpperLeft
};

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Workspaces:IWorkspaces

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Workspaces:IWorkspaces]]