VCOM:VectorWorks:Workspaces:IWorkspacePalette::GetWindowShadeState

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspacePalette

Gets the Window Shade state for the palette.

virtual VCOMError VCOM_CALLTYPE GetWindowShadeState(
bool& outWindowShadeState) = 0;

Parameters

outWindowShadeState bool& on output, if successful, a bool which if true, means that the palette should be window shaded.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.