VCOM:VectorWorks:Workspaces:IWorkspacePalette::SetHomeCornerOffset

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspacePalette

Sets the offset from the palette's home corner.

virtual VCOMError VCOM_CALLTYPE SetHomeCornerOffset(
Sint16 inHorizontalOffset,
Sint16 inVerticalOffset) = 0;

Parameters

inHorizontalOffset Sint16 the horizontal offset from the palette's home corner.
inVerticalOffset Sint16 the vertical offset from the palette's home corner.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

The offset is how far away from the home corner is the palette. For example, if the home corner is the lower-right hand side of the display, then a vertical offset of 10 signifies that the palette is 10 units away from the bottom of the display.