VCOM:VectorWorks:Workspaces:IWorkspacePalette::GetHomeCornerOffset

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspacePalette

Sets the offset from the palette's home corner.

virtual VCOMError VCOM_CALLTYPE GetHomeCornerOffset(
Sint16& outHorizontalOffset,
Sint16& outVerticalOffset) = 0;

Parameters

outHorizontalOffset Sint16& on output, if successful, the horizontal offset from the palette's home corner.
outVerticalOffset Sint16& on output, if successful, the vertical offset from the palette's home corner.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

The offset is how far away from the home corner is the palette. For example, if the home corner is the lower-right hand side of the display, then a vertical offset of 10 signifies that the palette is 10 units away from the bottom of the display.