VCOM:VectorWorks:Workspaces:IWorkspaceObjectInfoPalette

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Inherit VCOM:VectorWorks:Workspaces:IWorkspaceSizeablePalette

Interface

class IWorkspaceObjectInfoPalette : public IWorkspaceSizeablePalette
{
public:
  virtual VCOMError VCOM_CALLTYPE SetSeparatorOffsets(Sint16 inSeparatorOffsetOne, Sint16 inSeparatorOffsetTwo) = 0;
  virtual VCOMError VCOM_CALLTYPE GetSeparatorOffsets(Sint16& outSeparatorOffsetOne, Sint16& outSeparatorOffsetTwo) = 0;
  virtual VCOMError VCOM_CALLTYPE SetActivePanel(Sint16 inPanelIndex) = 0;
  virtual VCOMError VCOM_CALLTYPE GetActivePanel(Sint16& outPanelIndex) = 0;
};

Members

SetSeparatorOffsets Sets the offset of the separators that lie between the various panes in the Data panel for this palette.
GetSeparatorOffsets Gets the offset of the separators that lie between the various panes in the Data panel for this palette.
SetActivePanel Sets the active panel index.
GetActivePanel Gets the active panel index.

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Workspaces:IWorkspaces

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Workspaces:IWorkspaces]]