VCOM:VectorWorks:Workspaces:IWorkspaceObjectInfoPalette::GetSeparatorOffsets

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceObjectInfoPalette

Gets the offset of the separators that lie between the various panes in the Data panel for this palette.

virtual VCOMError VCOM_CALLTYPE GetSeparatorOffsets(
Sint16& outSeparatorOffsetOne,
Sint16& outSeparatorOffsetTwo) = 0;

Parameters

outSeparatorOffsetOne Sint16& Output parameter. Return the offset for the first separator.
outSeparatorOffsetTwo Sint16& Output parameter. Return the offset for the second separator.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.