VCOM:VectorWorks:Workspaces:IWorkspaceObjectInfoPalette::SetSeparatorOffsets

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceObjectInfoPalette

Sets the offset of the separators that lie between the various panes in the Data panel for this palette.

virtual VCOMError VCOM_CALLTYPE SetSeparatorOffsets(
Sint16 inSeparatorOffsetOne,
Sint16 inSeparatorOffsetTwo) = 0;

Parameters

inSeparatorOffsetOne Sint16 the offset for the first separator.
inSeparatorOffsetTwo Sint16 the offset for the second separator.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.