VCOM:VectorWorks:Workspaces:IWorkspaceTool

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Interface

class IWorkspaceTool : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE GetIdentifier(TXString& outIdentifier) = 0;
  virtual VCOMError VCOM_CALLTYPE SetUniversalName(const TXString& inName) = 0;
  virtual VCOMError VCOM_CALLTYPE GetUniversalName(TXString& outName) = 0;
  virtual VCOMError VCOM_CALLTYPE SetResourceManagerID(Sint16 inResourceID) = 0;
  virtual VCOMError VCOM_CALLTYPE GetResourceManagerID(Sint16& outResourceManagerID) = 0;
  virtual VCOMError VCOM_CALLTYPE SetShortcutKeyInfo(char inShortcutKey, Uint32 inKeyModifiers) = 0;
  virtual VCOMError VCOM_CALLTYPE GetShortcutKeyInfo(char& outShortcutKey, Uint32& outKeyModifiers) = 0;
  virtual VCOMError VCOM_CALLTYPE GetLastError(EWorkspacesError& outError) = 0;
};

Members

GetIdentifier Gets the workspace identifier for the menu item.
SetUniversalName Sets the universal name for the tool.
GetUniversalName Gets the universal name for the tool.
SetResourceManagerID Sets the Resource Manager ID for this item.
GetResourceManagerID Gets the Resource Manager ID if there is one.
SetShortcutKeyInfo Sets the shortcut key information.
GetShortcutKeyInfo Gets the shortcut key information.
GetLastError Gets the last error that was generated by the IWorkspaces interface.

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]