VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetToolUsingIdentifier

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the tool that corresponds to the given identifier.

virtual VCOMError VCOM_CALLTYPE GetToolUsingIdentifier(
const TXString& inIdentifier,
IWorkspaceTool** outTool) = 0;

Parameters

inIdentifier const TXString& the identifier that represents the desired tool.
outTool IWorkspaceTool** on output, if successful, a pointer to the tool.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.