VCOM:VectorWorks:Workspaces:IWorkspaceFile::GetToolSetUsingIdentifier

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Gets the tool set that corresponds to the given identifier.

virtual VCOMError VCOM_CALLTYPE GetToolSetUsingIdentifier(
const TXString& inIdentifier,
IWorkspaceToolSet** outToolSet) = 0;

Parameters

inIdentifier const TXString& the identifier that represents the desired tool set.
outToolSet IWorkspaceToolSet** on output, if successful, a pointer to the tool set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.