VCOM:VectorWorks:Workspaces:IWorkspaceFile::CreateToolPalette

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Creates a tool palette in the workspace if it does not exist.

virtual VCOMError VCOM_CALLTYPE CreateToolPalette(
const TXString& inIdentifier,
IWorkspaceToolPalette** outToolPalette) = 0;

Parameters

inIdentifier const TXString& the identifier to be used to represent this tool palette. Use the IWorkspaces interface to create this identifier.
outToolPalette IWorkspaceToolPalette** Output parameter. the created tool palette.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.