VCOM:VectorWorks:Workspaces:IWorkspaceFile::CreateTool

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Creates a tool in the workspace if it does not exist.

virtual VCOMError VCOM_CALLTYPE CreateTool(
const TXString& inIdentifier,
IWorkspaceTool** outTool) = 0;

Parameters

inIdentifier const TXString& the identifier to be used to represent this tool. Use the IWorkspaces interface to create this identifier.
outTool IWorkspaceTool** will be the newly created tool in the workspace.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.