VCOM:VectorWorks:Scripting:IPythonScriptEngine: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 13:47, 19 September 2013

Description

namespace VectorWorks::Scripting

..put some descriptoin in here...

Interface

...put the class definition, including the UUID, here...

Members

CompileScript
RequestPredefinedCode
ExecuteScript
Repository_RemoveValues
Repository_RemoveValue
Repository_GetValue
Repository_SetValue
Repository_GetValueNames
CallUserFunction
CallUserProcedure
ReportRuntimeWarning
ReportRuntimeError
DisplayScriptOptionsDlg

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IPythonScriptEngine interface:

typedef VCOMPtr<IPythonScriptEngine>  IPythonScriptEnginePtr;

Version

Available from: Vectorworks 2014

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]