VCOM:VectorWorks:Scripting:IPythonScriptEngine::CallUserProcedure

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonScriptEngine

This function is used to callback functions during execution of a script. For example, implementing a function that require to callback the script would use this call to execute the callback.

virtual VCOMErrorVCOM_CALLTYPE CallUserProcedure(
void* procedureRef,
PluginLibraryArgTable* arguments,
size_t argumentsCount) = 0;

Parameters

procedureRef void* Callback reference. This is provided through the Script Extension function parameter.
arguments PluginLibraryArgTable* Argument table to be passed to the procedure.
argumentsCount size_t Argument count in the table.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014