VCOM:VectorWorks:Scripting:IPythonScriptEngine::ReportRuntimeWarning

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonScriptEngine

Report a waring to the script engine. Errors collected during execution will be reported at the end of the execution with a dialog.

virtual VCOMErrorVCOM_CALLTYPE ReportRuntimeWarning(
const TXString& text) = 0;

Parameters

text const SDK:TXString& The warning text.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014