VCOM:VectorWorks:IToolInteractiveDraw: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
 
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 13: Line 13:
<interface>
<interface>
<code lang="cpp">
<code lang="cpp">
This interface supports in creating and updating temporary objects and adorner objects to provide interactive feedback. Please refer the individual methods for more details.
...put the class definition, including the UUID, here...
</code>
</code>
</interface>
</interface>
Line 22: Line 22:
<line>
<line>
[[VCOM:VectorWorks:IToolInteractiveDraw::GetObject|GetObject]]
[[VCOM:VectorWorks:IToolInteractiveDraw::GetObject|GetObject]]
</line>
<line>
[[VCOM:VectorWorks:IToolInteractiveDraw::AddNewOrGetExistingObject|AddNewOrGetExistingObject]]


</line>
</line>
Line 46: Line 42:
<line>
<line>
[[VCOM:VectorWorks:IToolInteractiveDraw::ClearAdorners|ClearAdorners]]
[[VCOM:VectorWorks:IToolInteractiveDraw::ClearAdorners|ClearAdorners]]
</line>
<line>
[[VCOM:VectorWorks:IToolInteractiveDraw::Setup|Setup]]


</line>
</line>
Line 68: Line 68:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2013
Available from: Vectorworks 2015
</version>
</version>



Latest revision as of 15:48, 18 September 2014

Description

namespace VectorWorks

..put some descriptoin in here...

Interface

...put the class definition, including the UUID, here...

Members

GetObject
RemoveObject
ClearObjects
GetAdorner
RemoveAdorner
ClearAdorners
Setup

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IToolInteractiveDraw interface:

typedef VCOMPtr<IToolInteractiveDraw>  IToolInteractiveDrawPtr;

Version

Available from: Vectorworks 2015

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]