VCOM:VectorWorks:IToolInteractiveDraw::RemoveAdorner

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:IToolInteractiveDraw. Removes given Adorner type object of given id from the adorner objects collection at ToolInteractiveDraw.

virtual voidVCOM_CALLTYPE RemoveAdorner(
EAdornerType adornerType,
Sint32 id = 0) = 0;

Parameters

adornerType EAdornerType no info.
id Sint32 no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.