VCOM:VectorWorks:IToolInteractiveDraw::GetAdorner

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:IToolInteractiveDraw. Used to create/get the Adorner type objects. Adorner type objects will remain the same size in any zooming levels and the color will remain as black color always.

virtual MCObjectHandleVCOM_CALLTYPE GetAdorner(
EAdornerType adornerType,
Sint32 id = 0) = 0;

Parameters

adornerType EAdornerType no info.
id Sint32 no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.