VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::GetToolSetAtIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

Gets the tool set at the given index.

virtual VCOMError VCOM_CALLTYPE GetToolSetAtIndex(
Sint16 inIndex,
IWorkspaceToolSet** outToolSet) = 0;

Parameters

inIndex Sint16 the index into the array of tool sets to get.
outToolSet IWorkspaceToolSet** on output, if successful, the tool set at the given index.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.