VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::GetSubToolForToolAtIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:08, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Gets the sub-tool for the given parent tool at the given index.

virtual VCOMError VCOM_CALLTYPE GetSubToolForToolAtIndex(
IWorkspaceTool* inParentTool,
Sint16 inIndex,
IWorkspaceTool** outChildTool) = 0;

Parameters

inParentTool IWorkspaceTool* the tool that contains all the other sub-tools.
inIndex Sint16 the index into the list of sub-tools that we want the tool for.
outChildTool IWorkspaceTool** on output, if successful, the child tool at the given index for the given tool.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.