VCOM:VectorWorks:Workspaces:IWorkspaceToolSet::AddChildTool: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Workspaces</code> Member o...)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolSet

Adds a Sub-Tool to the given tool in the tool set.

virtual VCOMError VCOM_CALLTYPE AddChildTool(
IWorkspaceTool* inParentTool,
IWorkspaceTool* inChildTool) = 0;

Parameters

inParentTool IWorkspaceTool* the tool that has been added as a tool button for this tool set.
inChildTool IWorkspaceTool* the sub-tool that should be added to the list of sub-tools for this tool button.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.