VS:WallFootPrint: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (transfer Orso to _c_)
m (Transfer Orso to _c_)
 
Line 35: Line 35:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:CBM-c-|_c_]], 2008 Jan. 07): This actually generates the footprint object in the parent container (active layer or whatever other parent). It doesn't only return a handle.
[[User:CBM-c-|_c_]], (2008.01.07): This actually generates the footprint object in the parent container (active layer or whatever other parent). It doesn't only return a handle.


([[User:CBM-c-|_c_]], 2011 Jan. 30): You might need to regen it using [[VS:ResetObject| ResetObject]] in order to actually see/use it in the drawing. Mind that this object is always a screen plane polyline, unregarded the active plane, and that its vertexes are all hidden.
[[User:CBM-c-|_c_]], (2011.01.30): You might need to regen it using [[VS:ResetObject| ResetObject]] in order to actually see/use it in the drawing. Mind that this object is always a screen plane polyline, unregarded the active plane, and that its vertexes are all hidden.
</remark>
</remark>



Latest revision as of 06:38, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the handle of a polyline representing the footprint of a wall.

FUNCTION WallFootPrint(
wallHandle :HANDLE) : HANDLE;
def vs.WallFootPrint(wallHandle):
    return HANDLE

Parameters

wallHandle HANDLE Handle to the wall

Return Value

Returns the handle of a polyline representing the footprint of a wall.

Remarks

_c_, (2008.01.07): This actually generates the footprint object in the parent container (active layer or whatever other parent). It doesn't only return a handle.

_c_, (2011.01.30): You might need to regen it using ResetObject in order to actually see/use it in the drawing. Mind that this object is always a screen plane polyline, unregarded the active plane, and that its vertexes are all hidden.

Example

VectorScript

PROCEDURE GetWallFootPrint;
VAR
h1, h2 :HANDLE;
BEGIN
h1 := FSActLayer;
h2 := WallFootPrint(h1);
END;
RUN(GetWallFootPrint);

Python


Version

Availability: from VectorWorks 10.0