VS:UnitVec: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(document: vector in Py 3-dimensional)
Line 29: Line 29:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
([[User:CBM-c-|_c_]], 2022.01.19) In Python the tuple returned is always 3-dimensional.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 03:53, 19 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the standard unit vector of the specified vector.

FUNCTION UnitVec(
Vect :VECTOR) : VECTOR;
def vs.UnitVec(Vect):
    return VECTOR

Parameters

Vect VECTOR Source vector.

Return Value

Returns a VECTOR.

Remarks

(_c_, 2022.01.19) In Python the tuple returned is always 3-dimensional.

Version

Availability: from All Versions