VS:SetWorkingPlane: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(fix)
 
(2 intermediate revisions by 2 users not shown)
Line 55: Line 55:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
In VW2012 this command seems not to do anything at all.
([[User:CBM-c-|_c_]] 2022.05.12): From Raymond Mullin: as of VW 2022 any working plane set with this routine doesn't persist after script's end. This routine works in this fashion since VW 2011.
</remark>
</remark>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 65: Line 65:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks10.0
Availability: from VectorWorks 10.0


</version>
</version>

Latest revision as of 06:48, 12 May 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the x, y, and z offset of the working plane as well as the x-, y-, and z-plane rotational values.

PROCEDURE SetWorkingPlane(
x :REAL;
y :REAL;
z :REAL;
xRotation :REAL;
yRotation :REAL;
zRotation :REAL);
def vs.SetWorkingPlane(x, y, z, xRotation, yRotation, zRotation):
    return None

Parameters

x REAL X-coordinate of the working plane
y REAL Y-coordinate of the working plane
z REAL Z-coordinate of the working plane
xRotation REAL X-coordinate of the rotation
yRotation REAL Y-coordinate of the rotation
zRotation REAL Z-coordinate of the rotation

Remarks

(_c_ 2022.05.12): From Raymond Mullin: as of VW 2022 any working plane set with this routine doesn't persist after script's end. This routine works in this fashion since VW 2011.

Version

Availability: from VectorWorks 10.0

See Also

VS Functions:

VS:GetWorkingPlane

VS Functions: [[VS:GetWorkingPlane]]