VS:SetStaticTextColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add usage limit)
m (Transfer Orso to _c_)
Line 52: Line 52:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2014 Apr. 27):  This only works during [[VS:CreateResizableLayout| dialog setup]], the color cannot be changed later, for example during event [[VS:Creating_a_Custom_Dialog_Box| SetupDialogC]].
([[User:CBM-c-|_c_]], 2014.04.27):  This only works during [[VS:CreateResizableLayout| dialog setup]], the color cannot be changed later, for example during event [[VS:Creating_a_Custom_Dialog_Box| SetupDialogC]].
</remark>
</remark>



Revision as of 05:38, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the color for the Layout Manager static Text

PROCEDURE SetStaticTextColor(
dialogID :LONGINT;
componentID :LONGINT;
red :INTEGER;
green :INTEGER;
blue :INTEGER);
def vs.SetStaticTextColor(dialogID, componentID, red, green, blue):
    return None

Parameters

dialogID LONGINT
componentID LONGINT
red INTEGER
green INTEGER
blue INTEGER

Remarks

(_c_, 2014.04.27): This only works during dialog setup, the color cannot be changed later, for example during event SetupDialogC.

Version

Availability: from Vectorworks 2010