VS:SetObjWallBreakMode

From Vectorworks Developer
Revision as of 06:47, 14 January 2017 by CBM-c- (talk | contribs) (wikify to remove extra spaces)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the break mode for an object in a wall.

  1. Full Break with Caps
  2. Full Break no Caps
  3. Half Break
  4. No Break

The object (objH) must be contained in wall (wallH) to succeed.

FUNCTION SetObjWallBreakMode(
objH :HANDLE;
wallH :HANDLE;
breakMode :INTEGER) : Boolean;
def vs.SetObjWallBreakMode(objH, wallH, breakMode):
    return Boolean

Parameters

objH HANDLE
wallH HANDLE
breakMode INTEGER

Return Value

True or False upon successful setting of the break mode.

False can occur for the following conditions:

  • objH is null
  • wallH is null

objH is not contained in wallH.

Version

Availability: from Vectorworks 2017