VS:SetLBItemDashStyle: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 54: Line 54:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
[[User:CBM-c-|_c_]] (2016.02.29): Expects a dash list index (not from the name list).
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 06:56, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the specified list browser item's dash style.

FUNCTION SetLBItemDashStyle(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
styleIndex :INTEGER;
lineWeight :INTEGER) : BOOLEAN;
def vs.SetLBItemDashStyle(dialogID, componentID, itemIndex, subItemIndex, styleIndex, lineWeight):
    return BOOLEAN

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
styleIndex INTEGER the dash line's style index
lineWeight INTEGER the dash line's line weight

Remarks

_c_ (2016.02.29): Expects a dash list index (not from the name list).

Version

Availability: from VectorWorks 12.0