VS:SetComponentPenWeights: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(Shorten OBJECT, reserved word)
 
(One intermediate revision by one other user not shown)
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION SetComponentPenWeights(object:HANDLE; componentIndex:INTEGER; leftPenWeight:INTEGER; rightPenWeight:INTEGER) : BOOLEAN;
FUNCTION SetComponentPenWeights(obj:HANDLE; componentIndex:INTEGER; leftPenWeight:INTEGER; rightPenWeight:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SetComponentPenWeights(object, componentIndex, leftPenWeight, rightPenWeight):
def vs.SetComponentPenWeights(obj, componentIndex, leftPenWeight, rightPenWeight):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 60: Line 60:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 20:08, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the left and right pen weights for a component in an object.

FUNCTION SetComponentPenWeights(
obj :HANDLE;
componentIndex :INTEGER;
leftPenWeight :INTEGER;
rightPenWeight :INTEGER) : BOOLEAN;
def vs.SetComponentPenWeights(obj, componentIndex, leftPenWeight, rightPenWeight):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
leftPenWeight INTEGER The pen weight of the component's left line.
rightPenWeight INTEGER The pen weight of the component's right line.

Remarks

VW2011: It seems that the right line doesn't get adjusted...

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:GetComponentPenWeights

VS Functions: [[VS:GetComponentPenWeights]]