VS:SetComponentFillColors

From Vectorworks Developer
Revision as of 20:06, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the fore and back fill colors of a component in an object.

FUNCTION SetComponentFillColors(
obj :HANDLE;
componentIndex :INTEGER;
fillForeColor :INTEGER;
fillBackColor :INTEGER) : BOOLEAN;
def vs.SetComponentFillColors(obj, componentIndex, fillForeColor, fillBackColor):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fillForeColor INTEGER The fore color of the fill.
fillBackColor INTEGER The back color of the fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:GetComponentFillColors

VS Functions: [[VS:GetComponentFillColors]]